[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Karolina's KDE 3.1RC5 broke my SDL development.

On Tuesday 17 December 2002 01:13 am, Karolina Lindqvist wrote:
> tisdagen den 17 december 2002 04.53 skrev Doug Holland:
> > Apparently, Karolina's KDE3.1RC5 packages came with its own version of
> > SDL, which conflicted with Sid's SDL packages and removed them. 
> > Unfortunately, there is no libsdl-dev package that has the SDL headers,
> > so my development work, which requires SDL has ground to a halt.
> >
> > Are there any easy workarounds to this?  If I try installing the Sid SDL
> > packages, dselect asks me to remove every KDE3.1 package on my system.
> The reason is that libsdl1.2debian-arts is built for the old aRts. So I
> simply rebuilt for the new version of aRts. I think the "official" KDE
> maintainers will get the same problem.
> That libsdl1.2-dev was not there, was just a mistake. I have put it there
> too. Obviously I have it installed myself, since otherwise I can't build
> KDE.
> > Of course, these kinds of issues wouldn't happen if KDE3 was in unstable
> > months ago like it should, but I'm not bitter...
> There are issues with KDE 3.* that I think are more important than the GCC
> 3.2 transition.
> Karolina

Karolina, I do appreciate your quick response to my question.  Well, I just 
tried installing libsdl1.2-dev again, and got the following errors:

># apt-get install libsdl1.2-dev
>Reading Package Lists... Done
>Building Dependency Tree... Done
>Some packages could not be installed. This may mean that you have
>requested an impossible situation or if you are using the unstable
>distribution that some required packages have not yet been created
>or been moved out of Incoming.
>Since you only requested a single operation it is extremely likely that
>the package is simply not installable and a bug report against
>that package should be filed.
>The following information may help to resolve the situation:
>Sorry, but the following packages have unmet dependencies:
>  libsdl1.2-dev: Depends: libsdl1.2debian (= 1.2.4-1) but 1.2.4-1+arts1.1-1 
>is to be installed
>E: Sorry, broken packages

Apparently, it is possible to install libsdl1.2-dev concurrently with KDE 
3.1RC5, but I haven't figured out the trick.  I also looked in the Karolina 
KDE 3.1RC5 directories and haven't found a substitute package.

I'm still trying to figure out how to solve this problem.  Now that I've 
calmed down enough to think, I remember that I had a similar problem when I 
installed the KDE 3.0.4 packages from kde.org, and I worked around that 
problem by installing an aRts-less version of SDL.  What do I need to do to 
get some SDL headers on my system?  (well, there's always downloading the SDL 
tarball and compiling myself...)

/me pines for a Debian equivalent of "rpm --nodeps --force"...

Reply to: