[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: KDE 3.0.3 problem with Kpackage

Hash: SHA1

On Wednesday 21 August 2002 15:05, Dale Kemp wrote:

>>> if I try to start it from a shell I get this:
>>> kpackage: error while loading shared libraries: libdb.so.2: cannot open
>>> shared object file: No such file or directory
>> You might like to try installing the libdb1-compat package from
>> unstable/sid.
>  I had the same problem this fixed it thanks, now you can tell the world
> why.

When you installed kde 3.0.3, you also upgraded libc6 to the Debian/unstable 
version. The maintainer for libc6 has recently removed the db1 compatibility 
layer from libc (upstream removd it a long time ago - the maintainer was 
keeping it in for compatibility reasons).

As we are early in the development of sarge, the libc maintainer thought now 
would be the best time to remove this compatibility layer, which has been 
depreciated for a long while.

This broke some packages in sid, for example apache, which still used db1 
(even though db2, 3 and 4 are all available and have compatibility layers for 

Anyway, as a temporary fix until the affected packages are fixed to use 
db[2,3,4], someone has created a package which returns libdb1 to your 
Debian/sid system, allowing the broken program to now work.

Kpackage in kde 3.0.3 (and possibly other programs) obviously seem to still 
require db1, for the time being at last.

Anyway, installing libdb1-compat should fix your system for the moment. If the 
kde 3.0.3 packages were in Debian proper, this would be worthy of a bug 
report to the BTS, but as they are not...

I'm glad that solved your problem.

Paul Cupis
- -- 

Version: GnuPG v1.0.7 (GNU/Linux)


Reply to: