[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: configure error on debian woody kde 2.2.2

Am Samstag, 27. Juli 2002 19:33 schrieb Thomas Ritter:
> Am Samstag, 27. Juli 2002 19:17 schrieb gerhard:
> > Sorry:
> > After apt-get install  kde-devel ./configure can find the
> > kde-headers now, but not the OpenGL headers, although libqt2
> > libqt-dev are the newest packets of my installation.
> ---------------------------------------
> Install auto-apt:
> 	apt-get install auto-apt
> Update the auto-apt database:
> 	auto-apt update ; auto-apt updatedb ; auto-apt update-local
> Go to your Source directory and execute:
> 	auto-apt run ./configure
> or to build a debian package, run (in the source directory)
> 	deb-make
> (package debmake, if you don't have it) and
> 	auto-apt run debian/rules binary
> If configure tries to access any file you don't have on your
> system, but which is available in the repositories in your
> /etc/apt/sources.list, you will be prompted if you want to
> install that package.
> [...]

Thank you Thomas, but unfortunateley I got the same error message 
without prompting for any package to install at this point (before 
that point, auto-apt asked me to install some packages, who have 
been installed after confirmation without any problems - great 
experience: this little tool called 'auto-apt'. Thanx for the hint)

The error message:
checking for GL/gl.h... yes
checking for GL/glu.h... yes
checking for GL/glut.h... yes
checking for GL/glx.h... yes
checking for the Qt OpenGL extension... no
configure: error: your system is not able to compile
an application that uses the Qt OpenGL extension!
Make sure the OpenGL headers are installed and Qt is compiled with 
support to compile kpovmodeler.
See the file REQUIREMENTS for further information.

debian:/home/gerhard/download/kpovmodeler/kpovmodeler-0.1.1# tail 
configure:8011: checking for the Qt OpenGL extension
configure:8040: /bin/sh ./libtool --silent --mode=link g++ -o 
conftest -O2 -fno-exceptions -fno-check-new 
-I/usr/local/kde/include -I/usr/include/qt -I/usr/X11R6/include    
-L/usr/X11R6/lib -L/usr/lib  conftest.C  -lkdecore -lqt -lpng -lz 
-lm -ljpeg  -lXext -lX11 -lSM -lICE  -ldnet  1>&5
/tmp/cct5txLt.o: In function `main':
/tmp/cct5txLt.o(.text+0x23): undefined reference to 
`QGLWidget::QGLWidget(QWidget *, char const *, QGLWidget const *, 
unsigned int)'
collect2: ld returned 1 exit status

Andreas Zehnder wrote:
> 2) If there are linker errors "undefined reference to 
> QGLWidget::*" then you have all headers installed, 
> but your Qt version comes without the OpenGL extension. 
> Either you have to recompile Qt or update your KDE and 
> Qt version and download KPovModeler 0.2. 
> The 0.2 version does not require the extension.

I got beside other packets the these packages installed: 
glutg3-dev nvidia-glx nvidia-glx-dev x-window-system 
x-window-system-core xlibmesa-dev xlibmesa3

What Kind of Qt version in debian supports the OpenGL extension?
I don't want to update now to KDE 3.1alpha to install 
KPovModeler 0.2

What is the right mailinglist to ask further Question?



To UNSUBSCRIBE, email to debian-kde-request@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Reply to: