[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

kdebase-libs2.2.2 breaks all regular user logins?

I'm not quite sure which caused this, but. . .

I had been burning ISO's of Woody from files I had copied from DVD. The DVD 
and CD-RW are on the same IDE port.

As One ot the CD's was burning away, I tried to check out the DVD, and my 
system locked up tighter than a drum!

After waiting many minutes for it to sort itself out I had to resort to 
hitting the reset button. During this session, I had also updated a few kde 
libs. When the system finally finished fixing all the file systems, I found 
that I could not log in as any regular user? Root could log in though?!?

I tried the usual moving the .kde* files and even created a new user, but no 
joy at all.

Since I had CD's of Woody from early Jan, thanks to the DVD, I re-installed 
everything, keeping my home partition intact (Good idea to have several 

Once I got this working, I started to update it bit by bit, since I'm on a 
pay-per-minute dialup access. After the last set of updates, that included 
updating kdebase-libs to 2.2.2 I found that I, once again, could not log into 
kde? Using the CD's I downgraded kdebase-libs and kdebase to2.2.1.0-6 and 
this restored my login?!?

Obviously, I've got a serious problem with libs, since no one else has 
reported this type of problem. Here is what I have installed under kde:

johngay@debian:~$ dpkg -l|grep kde
ii  kde-designer   2.3.0-final-1  QT GUI Designer (with KDE widget support)
ii  kde-games      2.2.19         The K Desktop Environment (Games and Toys)
ii  kde-i18n-engb  2.2.2-1        English (UK) i18n files for KDE
ii  kdebase      KDE core applications
ii  kdebase-audiol 2.2.2-14       KDE audio libraries amd modules for kdebase
ii  kdebase-crypto 2.2.2-1        KDE crypto control module
ii  kdebase-doc      Documentation for Applications in kdebase
ii  kdebase-libs      KDE libraries and modules for kdebase
ii  kdecarddecks   2.2.2-1        Card decks for KDE games
ii  kdelibs-dev    2.2.2-5        KDE core libraries (development files)
ii  kdelibs3       2.2.2-5        KDE core libraries (runtime files)
ii  kdelibs3-crypt 2.2.2-5        KDE core crypto libraries
ii  kdelibs3-doc   2.2.2-5        KDE core library documentation
ii  kdepasswd      2.2.2-5        A Password changer frontend for KDE
ii  kdepim-libs    2.1.1-4        KDE libraries amd modules for kdepim
ii  kdesdk-scripts 2.2.2-2        a set of useful development scripts for KDE
ii  kdetoys-doc-ht 2.2.2-2        KDE toys documentation in HTML format
ii  kdevelop       2.0.2-1        An IDE for Unix/X11
ii  kdevelop-data  2.0.2-1        Platform independent data files for the kdev
ii  kdevelop-doc   2.0.2-1        Documentation for the kdevelop package
ii  kdewallpapers      Some wallpapers for KDE
ii  libkdegames    2.2.2-2        KDE Games library and common files

Obvously, all the kde stuff should be 2.2.2, but since I had to downgrade 
kdebase and kdebase-libs to get my login working, somethign else must be 
causing a conflict. What other libs and such should I check to see where this 
conflict is coming from? And why would root still be able to log in, but no 
regular uses?

This is very strange indeed!

If I didn't have such a slow, expensive connection I've been wanting to try 
out Sorcerer Linux to keep a bit more up-to-date than Debian. I love Debian's 
apt and dpkg tools, but Sorcerer's ability to fetch source code directly from 
the app's homepage and compile it locally, fully optimised for your system 
sounds like a great way to keep up-to-date!

I hope someone can point me in the right direction!

Before I forget, Great job Chris and everyone! I especially like Chris' 
recent status update! Nice to see where we are heading! Keep up the great 


	John Gay

Reply to: