[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

KDE 2.2.2 crash when it's compiled when objprelink

I don't know if this is the appropiate place to discuss objprelink problems 
with KDE, but if someone can help me I apreciate it a lot.
I tried to build KDE 2.2.2 from the Debian  sources generating binary 
packages compiled with objprelink and optimizations for 686.
I get objprelink form: 

I compiled Qt with the patch from this page with the  Debian sources 
generating a binary debian package.
After compiling and installing the Qt and kdelibs binaries that I generated I 
have no problems, but I don't notice anything especial.
Later I compiled kdebase always from the Debian sources with objprelink.
After installing these packages kdm crashes when it want to display the 
background image, but fortunatelly I can login. KDE seems to load more faster 
than ever but crashed when it want to launch kicker and absolutelly nothing 
>From IceWM I started konqueror from an xterm and it loads amazing fast and 
their performance are very great but always crashed when I want to see the 
sidebar or want to display everything. On the contrary konsole is the only 
application that works and also loads fast.

I'm running woody with KDE 2.2.2 and their dependences from unstable with 
>From the Linux From Scratch project also I read this:
 "You'll need the latest version of binutils (2.11.2 at this point), and if 
any of glibc, gcc or binutils were compiled with optimizations there is a 
chance that everything you prelink will segfault when run.  Prelinking failed 
for me on my LFS 2.4.3 system where those were built with optimizations; on a 
LFS 3.0 system where glibc, gcc and binutils were compiled with no 
optimizations and everything else was built -O3 -march=i386 -mcpu=i686, 
prelinking worked fine.  Proceed with caution."

Also I don't have any problems compiling KDE with objprelink.
Are there anyone that enjoy with objprelink on Debian?
Any help will be sincerelly appreciated, I felt the speed of objprelink on my 
P II 350, but I can't applied.

Reply to: