[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

MIDI not working with Debian-KDE and new policy of reverting back to alsa-0.5

I can get alsa-0.9 to play midi files from the command line (e.g., with the
pmidi command from the pmidi-0.9 package) if (1) I follow the instructions in
modules/alsa-driver/INSTALL, and if (2) after every boot I run

sfxload 8MBGMSFX.SF2

to load the soundfonts from the CD that came with my SB Live value card.

I used to have no problem with MIDI under Debian-KDE with alsa-0.9, but such
is no longer the case. Under the control centre (Midi - control center) the
area for "select the midi device you want to use" is completely blank.
Under information/sound (Sound - control center) there is a remark that

If I run kmid from the command line, I get the following error message:

Sorry, this KMid version was compiled without
ALSA support but you're using ALSA .
Please compile KMid for yourself or tell the people
at your Linux distribution to compile it themselves.

If I go ahead and attempt to play a midi example with kmid anyhow, I get the
following message.

There are no midi ports !

There is also a way to configure midi from kmid, but again I get a blank
screen with no input possible similar to the "Midi - control center" case
mentioned above.

Last time I had MIDI trouble on Debian-KDE it had exactly these symptoms
(blank control screen with no input possible), and the fix (as recommended
by Ivan Moore and which worked at the time) was to always use the alsa
version of libraries.  Currently, that is what I am doing for my Debian
woody system. I have libarts-alsa and libkmid-alsa installed (both versions
4:2.2.2-5).  I had libesd0 0.2.23-3 installed, but I noticed there was
an alsa version of that so I recently also tried
libesd-alsa0 version 0.2.23-3, but that made no difference to the problem.

Can anybody here confirm the alsa-0.9 midi problems I am having with KDE,
and/or recommend a fix?

BTW, I am using alsa-0.9 (the driver is compiled for kernel 2.4.17 using the
alsa-source package version 0.9+0beta10-6) because libkarts-alsa and
libkmid-alsa depend on libasound2 which is built from libalsa 0.9 source,
and the alsa site recommends the version 0.9 driver for the 0.9 library.
However, I notice libesd-alsa0 depends on libasound0 that is built from
libalsa-0.5 which should go with the 0.5 driver! And to compound this
confusion recent builds of kmix have reverted to depending on libasound1
rather than the previous libasound2.  When I put in a wishlist bug report
about that (#132015,
the response from Daniel was "Compiling against alsa 0.9 is not recommended
due to the constantly changing API and ABI, thus it's staying with 0.5. I
have no intention of changing this."

Do alsa-0.5 drivers actually work with libasound2 or should Daniel also
revert libarts-alsa and libkmid-alsa to depend on libasound1 rather than
libasound2 to be consistent with the changed (from when Ivan Moore was the
maintainer) Debian-kde-alsa policy? Although I would prefer to see alsa-0.9
working with Debian-kde, I am willing to go along with a change back to
alsa-0.5 so long as it is done consistently.  But the dependency mixture we
have now on both alsa-0.5 and alsa-0.9 libraries is not right, and might be
the source of my midi troubles.


email: irwin@beluga.phys.uvic.ca
phone: 250-727-2902	FAX: 250-721-7715
Dr. Alan W. Irwin
Department of Physics and Astronomy,
University of Victoria, P.O. Box 3055,
Victoria, British Columbia, Canada, V8W 3P6

Linux-powered astrophysics

Reply to: