[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

What to do about libpng-dev?

On Thursday 03 January 2002 12:45 am, Ivan E. Moore II wrote:
> All I did with a new libqt upload was force a
> resolution before the problem occured.   libpng3 is not
> backwards compatable and yet both -dev packages provide
> libpng-dev.  

OK.  The problem seems to be with libpng-dev.  I see that 
the package libpng-dev conflicts with itself!  Is that possibly 
Shouldn't the conflicts and depends be as follows?
libpng-dev conflicts with libpng2-dev and provides libpng2-dev
libpng2-dev conflicts with libpng-dev and provides libpng-dev

If that is the way it should be, then we ought to file a bug 
against lib libpng-dev for having a typo in its "conflicts" 
field?  (It lists a conflict with libpng-dev where it should 
list a conflict with libpng2-dev.)  

Will Ivan or some other guru please comment so a bug can be 
filed to alert Phillipe Troin (maintainer of libpng-dev) of this 

Or is the problem more complicated than that?


Oliver Johns <ojohns@metacosmos.org>
San Francisco, California USA
GPG Fingerprint=BE4A C1B8 EB0D 8FD9 737D  CE4A 1E56 BF9B A2AC 

Reply to: