[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: resolved: compiling kde3 stuff under Debian

On Thu, Oct 18, 2001 at 11:38:38PM +0200, Tomas Pospisek wrote:
> You might remember my last request for help. So now I've made a chrooted
> debian installation, popped rkrusty's libqt3
> package and kdebase-cvs_3.0-0.alpha1-1 fragments in it and:
> tpo2:rkrusty/kde3.0/source/kdebase-cvs-3.0-0.alpha1# debian/rules binary
> [...]
> checking for Qt... configure: error: Qt (>= Qt 3.0.0) (libraries) not
> found. Please check your installation!
> For more details about this problem, look at the end of config.log.
> make: *** [build-stamp] Error 1
> So aparently I'm not the only one who's got something wrong...
> from the config.log:
> configure:5510: gcc -o conftest -ansi -W -Wall -pedantic -Wshadow
> -Wpointer-arith -Wmissing-prototypes -Wwrite-strings -D_XOPEN_SOURCE=500
> -D_BSD_SOURCE -g -O2
>   -I.  -I/usr/X11R6/include  -D_REENTRANT  conftest.c -L/usr/X11R6/lib
> -ljpeg -lm 1>&5
> configure: 5550: /usr/include/jpeglib.h
> taking that
> configure:5684: checking for Qt
> configure: 5748: /usr/include/qt/qstyle.h
> taking that
> tried NO
> tried /usr/share/qt/lib
> tried /usr/share/qt
> tried /usr/lib/qt3/lib
> tried /usr/lib/qt3
> tried /usr/lib/qt/lib
> tried /usr/lib/qt
> tried /usr/X11R6/lib
> tried /usr/lib
> tried /usr/local/qt/lib
> tried /usr/X11R6/lib
> configure:5860: rm -rf SunWS_cache; c++ -o conftest -ansi
> -D_XOPEN_SOURCE=500 -D_BSD_SOURCE -Wbad-function-cast -Wcast-align -Wundef
> -Wconversion -fno-builtin -Wnon-virtual-dtor -Wno-long-long -g -O2 -Wall
> -pedantic -W -Wpointer-arith -Wmissing-prototypes -Wwrite-strings
> -fno-exceptions -fno-check-new -I/usr/include/qt -I.  -DPIC -fPIC
> -lpthread conftest.C  -lqt-mt -lpng -lz -lm -ljpeg  -lXext -lX11 -lSM
> -lICE  -lresolv 1>&5
> /usr/bin/ld: cannot find -lqt-mt
> [...]
> So all the new kde packages seem to be depending on qt3-mt now :-) !

oh yea..forgot to tell people that. :)  I found out just by accident as
I have it installed by default on the box I'm building kde3 stuff on...I 
noticed when I was looking at the deps and found libqt3-mt was listed...


Ivan E. Moore II
GPG Fingerprint=F2FC 69FD 0DA0 4FB8 225E 27B6 7645 8141 90BC E0DD

Reply to: