[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: audiocd protocol yet again

On Wed, Jul 25, 2001 at 11:25:11PM +0200, Michael Schuerig wrote:
> Hello,
> I've seen that it has been asked before, but still I don't get the 
> "audiocd:/" protocol to work. I get the error message "The file of 
> directory / does not exist." I'm using ide-scsi and the sg module is 
> loaded. It doesn't make a difference for this error message, whether 
> /dev/sg0 is readable or not. Also, XMMS does work. I'm using an 
> automounter for /cdrom (symlinked to /var/autofs/cdrom/cdrom), but this 
> should not interfere.

I was having this same problem.  I discovered that Paranoia uses
_two_ devices to work its magic.  So, if your CD-ROM is on /dev/scd0,
Paranoia will want to use /dev/sg0 also.  Permissions for both must,
of course, allow you read/write access.  On my system, it was the sg
device that I couldn't get to; I changed its group to cdrom, which is
probably not completely kosher, but it works :)

I also tried telling audiocd to use /dev/sg0, but it didn't like that.
It worked when I put in /dev/scd0.  It also worked for me with
auto-detection, and I have two CD-ROMs (one is a CD burner).


Michael Ashton <data@ieee.org>
"My attitude toward progress has passed from antagonism to boredom. I 
have long ceased to argue with people who prefer Thursday to 
Wednesday because it is Thursday."
    -- G. K. Chesterton

Reply to: