[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: apt-get upgrade to KDE 2.1.1 failed for potato-ppc

On Sun, Jun 03, 2001 at 11:29:08PM -0500, Tim Fairbank wrote:
> I have a stable Debian 2.2r3 system with KDE 1.1.2
> installed. When I attempted to use the packages from
> kde.debian.net to upgrade to KDE 2.1.1, the upgrade failed.
> The issue appears to be a dependency on libmng1, which does
> not exist in potato. What's worse, the version of
> libmng1 in woody depends on libc6 >= 2.2.2-2, so I
> can't just build from source and install by hand.

Sure you can. 
apt-get --build source libmng1 (if you point at unstable)

else find libmng sources in the pool
" "                   libmng_1.0.1-1.dsc
" "                   libmng_1.0.1.orig.tar.gz

dpkg-source -x libmng_1.0.1-1.dsc
cd libmng-1.0.1
fakeroot debian/rules binary
cd ..
lintian *.deb 
dpkg -i *.deb

> I would need to upgrade the whole system...which I'm
> resisting, since it's running perfectly now.
> Here are the details:
> Any suggestions?                                                                                                      

Gordon Sadler

Reply to: