[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: libqt2.2(-dev) does not conflict libqt2(-dev)??

> ii  libqt2         2.0.2-1.1      Qt GUI Library (runtime version).
> ii  libqt2-dev     2.0.2-1.1      Qt GUI library (development version).
> un  libqt2.1       <none>         (no description available)
> un  libqt2.1-dev   <none>         (no description available)
> rc  libqt2.2       2.2.3-0.potato Qt GUI Library (runtime version).
> ii  libqt2.2-dev   2.2.3-0.potato Qt GUI development headers, static libraries
> Is it correct that libqt2 and libqt2.2 can be installed at the same time?

libqt2.2-dev replaces libqt2-dev so as long as you install 2.2 after your ok.
same with libqt2.2 and libqt2.  and yes..you can have libqt2, libqt2.1
and libqt2.2 installed at the same time...it's not recommended...but you

> If this is normal, what is going wrong then when I try to compile 
> kpgpcrypt-2.0.1. It looks like qt2(.2)-dev is broken:

> make[3]: Entering directory `/home/gerralt/test/kpgpcrypt-2.0.1/kpgpcrypt'
> g++ -DHAVE_CONFIG_H -I. -I. -I.. -I/usr/include/qt -I/usr/X11R6/include  
> -I/usr/include/kde    -O2 -fno-exceptions -fno-rtti -fno-check-new  -c 
> qconfig.cpp
> In file included from /usr/include/qt/qfile.h:42,


> I hope that someone can tell me what went wrong....

not sure...either you need to re-install your -dev package for qt or kpgpcrypt
is broken.


Ivan E. Moore II
GPG Fingerprint=F2FC 69FD 0DA0 4FB8 225E 27B6 7645 8141 90BC E0DD

Reply to: