[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#656599: default-jdk: Java JDK not installable on squeeze

2012-01-20 12:34, Jörg Kurlbaum skrev:
> Package: default-jdk
> Severity: important
> On my very basic squeeze installation default-jdk and other java packages are
> not installable due to dependecy problems. The packages openjdk-6-jdk is also not installable
> Output:
> root@fff:~# LANG=C apt-get install openjdk-6-jdk
> Reading package lists... Done
> Building dependency tree       
> Reading state information... Done
> Some packages could not be installed. This may mean that you have
> requested an impossible situation or if you are using the unstable
> distribution that some required packages have not yet been created
> or been moved out of Incoming.
> The following information may help to resolve the situation:
> The following packages have unmet dependencies:
>  openjdk-6-jdk : Depends: openjdk-6-jre (>= 6b18-1.8.10-0+squeeze2) but it is not going to be installed
> E: Broken packages

6b18-1.8.10-0+squeeze2 are currently found in the Debian security repository.

> I suspect some misconfiguration of apt. But could not find any hints

try add
deb http://security.debian.org/ squeeze/updates main contrib non-free
to /etc/apt/sources.list

and then re-run
apt-get update
apt-get install openjdk-6-jdk


Reply to: