[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: RFS: swt-gtk 3.7-1

Just to warn everyone, this upload is going to break the following
packages, since the binary packages change name to *-3.7-*:


The first two are maintained by the pkg-java-maintainers team, and Tony
Mancill has uploaded versions of the third package, so we'll need to
prepare new version of those too. I can handle the first couple but will
need a sponsor.


On 25/06/11 13:58, أحمد المحمودي wrote:
> Hello,
>   I hope you would sponsor the upload of package "swt-gtk" for unstable.
>   It builds these binary packages:
>   libswt-gtk-3.7-java - Standard Widget Toolkit for GTK+ Java library
>   libswt-gtk-3.7-jni - Standard Widget Toolkit for GTK+ JNI library
>   libswt-gnome-gtk-3.7-jni - Standard Widget Toolkit for GTK+ GNOME JNI library
>   libswt-mozilla-gtk-3.7-jni - Standard Widget Toolkit for GTK+ Mozilla JNI library
>   libswt-cairo-gtk-3.7-jni - Standard Widget Toolkit for GTK+ Cairo JNI library
>   libswt-glx-gtk-3.7-jni - Standard Widget Toolkit for GTK+ GLX JNI library
>   libswt-webkit-gtk-3.7-jni - Standard Widget Toolkit for GTK+ WebKit JNI library
>   libswt-gtk-3.7-java-gcj - Standard Widget Toolkit for GTK+ native library
>   Here's the changelog entry:
> swt-gtk (3.7-1) unstable; urgency=low
>   * New upstream release.
>   * Mass rename 3.6[.2] => 3.7
>   * Updated arch64.diff patch for new upstream release.
>   * Removed 02-webkit_linkage and 04-fix-webkit-includes patches as they got
>     applied upstream.
>   * debian/control: Bumped Standards-Version to 3.9.2, no changes needed.
>   * Added 01-as-needed.diff patch to use -Wl,--as-needed when linking
>   * Added debian/libswt-gtk-3.7-java.lintian-overrides
>   As required, I tested the package against latest version of lintian 
>   and it is lintian clean.
>   The package can be found on Git:
>   ssh://git.debian.org/git/pkg-java/swt-gtk.git
>   Thanks...

Reply to: