[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#577164: marked as done (java-common: Add to FAQ: How to link javadocs for libraries)

Your message dated Tue, 29 Jun 2010 16:04:54 +0000
with message-id <E1OTdIs-0005hV-69@ries.debian.org>
and subject line Bug#577164: fixed in java-common 0.37
has caused the Debian Bug report #577164,
regarding java-common: Add to FAQ: How to link javadocs for libraries
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact owner@bugs.debian.org

577164: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=577164
Debian Bug Tracking System
Contact owner@bugs.debian.org with problems
--- Begin Message ---
Package: java-common
Version: 0.34
Severity: wishlist

I don't have the text for this FAQ entry, but at least I got from Niels that 
his package libfreemarker is a good example.

The idea is to have an FAQ item related to this text in section 2.4 of policy:

"Java library packages should compile the javadoc API of the library. The API 
must link against the javadoc API of the libraries it depends on. This 
includes the core java classes, which are provided by default-jdk-doc. The API 
must be registered with doc-base and must be installed in 
/usr/share/doc/<package>/api/ or /usr/share/doc/<package>/api-<component>/."

-- System Information:
Debian Release: squeeze/sid
  APT prefers testing
  APT policy: (500, 'testing')
Architecture: amd64 (x86_64)

Kernel: Linux 2.6.32-trunk-amd64 (SMP w/4 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash

java-common depends on no packages.

java-common recommends no packages.

Versions of packages java-common suggests:
ii  default-jre                   1.6-34     Standard Java or Java compatible 
ii  equivs                        2.0.8      Circumvent Debian package 

-- no debconf information

Attachment: signature.asc
Description: This is a digitally signed message part.

--- End Message ---
--- Begin Message ---
Source: java-common
Source-Version: 0.37

We believe that the bug you reported is fixed in the latest version of
java-common, which is due to be installed in the Debian FTP archive:

  to main/j/java-common/default-jdk-doc_0.37_all.deb
  to main/j/java-common/default-jdk_1.6-37_amd64.deb
  to main/j/java-common/default-jre-headless_1.6-37_amd64.deb
  to main/j/java-common/default-jre_1.6-37_amd64.deb
  to main/j/java-common/gcj-native-helper_1.6-37_amd64.deb
  to main/j/java-common/java-common_0.37.dsc
  to main/j/java-common/java-common_0.37.tar.gz
  to main/j/java-common/java-common_0.37_all.deb

A summary of the changes between this version and the previous one is

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 577164@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
Niels Thykier <niels@thykier.net> (supplier of updated java-common package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)

Hash: SHA1

Format: 1.8
Date: Mon, 28 Jun 2010 00:07:15 +0200
Source: java-common
Binary: java-common default-jre default-jre-headless default-jdk default-jdk-doc gcj-native-helper
Architecture: source all amd64
Version: 0.37
Distribution: unstable
Urgency: low
Maintainer: Debian Java Mailing List <debian-java@lists.debian.org>
Changed-By: Niels Thykier <niels@thykier.net>
 default-jdk - Standard Java or Java compatible Development Kit
 default-jdk-doc - Standard Java or Java compatible Development Kit (documentation)
 default-jre - Standard Java or Java compatible Runtime
 default-jre-headless - Standard Java or Java compatible Runtime (headless)
 gcj-native-helper - Standard helper tools for creating gcj native packages
 java-common - Base of all Java packages
Closes: 577164
 java-common (0.37) unstable; urgency=low
   * Updated and synced the Java FAQ.
     - contains a example of how to link with system javadocs.
     (Closes: #577164)
   * Renamed default-jdk-builddep to gcj-native-helper.
   * Removed useless install files and moved the override files
     to a location where dh_lintian finds them.
   * Removed some unused overrides.
   * Updated current list of maintainers in d/copyright
     (based on current list of Uploaders).
 6b2c758d8d299a9503e9b826ea90fd0f7b47b4c5 1195 java-common_0.37.dsc
 fcb1f87512d04c5e0ea03e2b20b10226ae673a0b 50355 java-common_0.37.tar.gz
 b7d2877b3fad1c13abeded35707b671f2856c7ef 63396 java-common_0.37_all.deb
 aff0a561d76abd0731f79463bc734d61fd2e1c96 6982 default-jdk-doc_0.37_all.deb
 bb16c71deef76cc1c8d4dc506d93400ae1393efe 826 default-jre_1.6-37_amd64.deb
 9e952a731916bfce3524b743938d342cfbfdf2ca 7210 default-jre-headless_1.6-37_amd64.deb
 dce2bd154e7b26daa606fec6c28c858a866471ef 824 default-jdk_1.6-37_amd64.deb
 8ccc236ce6ea8a0d9a34bbabcbfada31ce33017f 854 gcj-native-helper_1.6-37_amd64.deb
 4b068864d090e98c563675257767d90a484dd1ae9b38c083242c837689697e34 1195 java-common_0.37.dsc
 62d86b739bc520d360a7782cbb5d98e2df32c1b11ad51fc29869e74e3684f790 50355 java-common_0.37.tar.gz
 e2da542cfe6cbab54de5b384c4973d2599b3bc089ceb56378f425d545eb62c14 63396 java-common_0.37_all.deb
 2b323c110a13e7ed04fcf87ccbd8de470d82f81ae0fad50c9caa947da0dd38ba 6982 default-jdk-doc_0.37_all.deb
 886290aff76d6fda00fbc02739eefdee6605b7cdb977762b4ad18f5587cdeefc 826 default-jre_1.6-37_amd64.deb
 6f8d1b7019ec420ae22dce6f43c1cd07e79067cf60d48877d9314243de92ea5f 7210 default-jre-headless_1.6-37_amd64.deb
 dc9e7a14cb4e91403fa2ba61a85585923c9a70bf46620951a794e5c44c522280 824 default-jdk_1.6-37_amd64.deb
 7c749f6f28b94ae9fb2e7fc5a91c24f00de6baf10f0c5f593ae7d356cf56d626 854 gcj-native-helper_1.6-37_amd64.deb
 d94023d40e1b5637143eba32fea2d2b5 1195 java optional java-common_0.37.dsc
 3d7c690a225a3e57310e7d0515ca213c 50355 java optional java-common_0.37.tar.gz
 ac0ec07bfc50b53ec1500b561811200e 63396 java optional java-common_0.37_all.deb
 60a0f81f6acdcdcc1e9a36d909df7e2c 6982 doc optional default-jdk-doc_0.37_all.deb
 55765168c0aa9e2b592bddc37de529ab 826 java optional default-jre_1.6-37_amd64.deb
 e775a3e4d3ac8b271b3676b14a5bd4b1 7210 java optional default-jre-headless_1.6-37_amd64.deb
 a0aa76c02001be2a18c805ccdab5512b 824 java optional default-jdk_1.6-37_amd64.deb
 46dba661dbbe781422f7cd673b3aa275 854 java optional gcj-native-helper_1.6-37_amd64.deb

Version: GnuPG v1.4.10 (GNU/Linux)


--- End Message ---

Reply to: