[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

RFS: libhamcrest-java (fixes regression)


The recent upload of libhamcrest-java had a regression that made it exclude OSGi-metadata from the jar files and causes eclipse to break (at least build-time and quite possibly also runtime). I have prepared a Team Upload addressing this issue as well as a few other things.

The latest changelog entry for reference:
libhamcrest-java (1.1-8) unstable; urgency=low

  * Team upload.
  * Re-added OSGi-metadata to the jar files.
  * Removed depends on JRE; which is no longer needed per the Java Policy.
  * Removed some B-D-I that appeared twice.
  * Added missing description to a patch.
  * Fixed clean target - it forgot to remvoe some maven-helper files.

 -- Niels Thykier <niels@thykier.net>  Sun, 27 Jun 2010 17:29:24 +0200

The changes are available from the pkg-java SVN and can also be fetched from mentors via dget:

dget http://mentors.debian.net/debian/pool/main/l/libhamcrest-java/libhamcrest-java_1.1-8.dsc

When checking out from the SVN you can see the changes from the last upload by using:

svn diff -r12665:12667

Thank you in advance,

Reply to: