[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Multiple versions of libasm*-java

On Tue, Jun 15, 2010 at 1:44 PM, Onkar Shinde <onkarshinde@gmail.com> wrote:
> On Sat, Jun 5, 2010 at 4:16 AM, Damien Raude-Morvan <drazzib@drazzib.com> wrote:
> <snip>
>> From my last build test neither libspring-2.5-java nor libspring-java (3.0)
>> can be built with libasm3-java (fail to build with errors regarding
>> ClassVisitor interface, IIRC).
>> Don't take it as a -1 against your proposal, but it's a "call for patch" on
>> those libspring-* packages before RM old ASM packages :)
> </snip>
> The problem was with changed API of ClassReader. After going through
> the API differences bet 2.x and 3.x version as mentioned at [1] I was
> able to produce the patch. The changes have been committed to pkg-java
> svn. Can you please upload the package?
> Please note that I have also added a new package
> libspring-aspects-2.5-java. So it will go through binary NEW queue.

Oops. The link to API differences details is


Reply to: