[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

[Solved] Re: Building java packages with sbuild.

Le Sun, May 30, 2010 at 11:37:34PM +0100, Roger Leigh a écrit :
> Are you using sbuild with sudo or schroot ($chroot_mode in
> sbuild.conf)?
> If you're using sudo, the chroot setup is entirely down to you, and
> you need to make sure /proc, /sys etc. are mounted e.g. in your
> fstab.  sudo isn't recommended nowadays, though; schroot is much
> more flexible.
> If you're using schroot, /proc will be automatically mounted for all
> chroot types except "plain", which is exactly like sudo: you need to
> set it up yourself.  For all other chroot types, e.g. directory,
> lvm-snapshot etc., /proc will be automatically mounted (unless you
> deliberately remove it from the mount-defaults file).

Dear Roger,

thank you very much, this was exactly the source of the problem.

In the computer where /proc was not mounted, /etc/schroot/schroot.conf did
not provide a type for the sid schroot, which then defautled to plain.
Indicating type=directory solved my problem.  It is my mistake that I have
misconfigured this system and that it did not use the configuration files in

When I was trying to solve my problem by myself, I looked for “/proc” as a
keyword in the documentation and did not find a hint that not having it mounted
was a symptom of not using the type I intended. If you think that others may
make a similar error, how about the following patch to the schroot

diff --git a/man/schroot.conf.5.in b/man/schroot.conf.5.in
index 40cec0d..92e08b9 100644
--- a/man/schroot.conf.5.in
+++ b/man/schroot.conf.5.in
@@ -133,7 +133,8 @@ Plain and directory chroots
 Chroots of type \[oq]plain\[cq] or \[oq]directory\[cq] are directories
 accessible in the filesystem.  The two types are equivalent except for the fact
-that directory chroots run setup scripts, whereas plain chroots do not.
+that directory chroots run setup scripts, whereas plain chroots do not. As a
+consequence, virtual filesystems like \f[BI]/proc\fP are not mounted in plain chroots.
 Additionally, directory chroots implement the \fBfilesystem union chroot\fP
 options (see \[lq]\fIFilesystem Union chroot options\fP\[rq], below).

Have a nice day,


Reply to: