[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: RFS: pleiades - Japanese Language package for Eclipse using Dynamic AOP - IANADD

Hideki Yamane wrote:
> Dear mentors (CC: debian-java@lists.debian.org),
>  I am looking for a sponsor for my package "pleiades", Japanese Language package 
>  for Eclipse. It is very popular for Japanese Eclipse users. Its newest release 
>  is downloaded about 50,000 times.
> * Package name    : pleiades
>   Version         : 1.3.1-dfsg-1
>   Upstream Author : Shinji Kashihara
> * URL             : http://mergedoc.sourceforge.jp/
> * License         : Eclipse Public License 1.0
>   Section         : devel
>  It builds these binary packages:
>  pleiades   - Japanese Language package for Eclipse using Dynamic AOP, Pleiades
>  The package appears to be lintian clean.
>  My motivation for maintaining this package is: improve Japanese desktop envrioment
>  The package can be found on mentors.debian.net:
>  - URL: http://mentors.debian.net/debian/pool/main/p/pleiades
>  - Source repository: deb-src http://mentors.debian.net/debian unstable main contrib non-free
>  - dget http://mentors.debian.net/debian/pool/main/p/pleiades/pleiades_1.3.1-dfsg-1.dsc
>  I would be glad if someone uploaded this package for me. 


Thanks for taking your time to package this; it is much appreciated. I
have had a look at your package, but as the subject says, I am not a DD.

It would be nice if it could be installed beneath /usr/share/eclipse/
rather than /usr/lib/eclipse/ because it is a large arch all package.
  However it did not work when I tried to move it (even when symlinking
from /usr/lib/eclipse/). I think it complained because it could not find
the eclipse.ini file[1].

pleiades failed without libjavassist-java present; I think you should
also add libcommons-lang-java and libcommons-io-java to Depends (since
they are also mentioned in the classpath of pleiades's jar file).
  I did not test if they are strictly required (I already have those
packages installed due to other packages). Even if they are not strictly
 required, I believe a recommends or a suggests is in order.

I am a little unsure about whether pleiades should recommend a JVM. That
being said, eclipse (and therefore also pleiades) is an X11 application,
so if anything it should recommend default-jre and not the -headless.
  But I would like to hear you reason for recommending

As for building, I think you should Build-Depend on default-jdk instead
of openjdk-6-jdk | gcj-jdk. Then set (and export) JAVA_HOME to

Once again, thanks for packaging this.


[1] Guessed from the stack trace rather than the error message, which
was written in Japanese.

Attachment: signature.asc
Description: OpenPGP digital signature

Reply to: