[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: junit dependency not working

Le dimanche 06 décembre 2009 23:09:37, Giovanni Mascellani a écrit :
> Hi all.

Hi Giovanni,

> I have an annoying I'm not able to sort out. This is with freehep-util.
> The build is ok in my sid, but doesn't work in cowbuilder sid. It fails
> because maven says it's not able to find junit (but the build log
> clearly shows that both junit and junit4 have been installed).

I don't know what's wrong with your sid, but it doesn't build on mine (whether 
inside or outside chroot).

> The source I've used is here:
> http://poisson.phc.unipi.it/~mascellani/debian/freehep-util_2.0.2-2.dsc
> The maven error is:
> > Missing:
> > ----------
> > 1) junit:junit:jar:debian

There is no "debian" version of junit.

In fact, there is :
- junit:junit:jar:3.x (from junit package)
- junit:junit:jar:4.x (from junit4 package)

AFAIK, your should fix your debian/maven.rules and replace
junit junit jar s/3\..*/3.x/ *
junit junit jar s/.*/3.x/ *
[as there is no version specified in upstream pom.xml]

Damien Raude-Morvan - http://damien.raude-morvan.com/

Attachment: signature.asc
Description: This is a digitally signed message part.

Reply to: