[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Typesetting Japanese

Adam C Powell IV wrote:
Hello and thanks for the reply,

On Sat, 2007-10-20 at 15:30 +0800, LUK ShunTim wrote:
Adam C Powell IV wrote:

I am trying to print something in Japanese, but am having trouble with
both LaTeX and OpenOffice.

In LaTeX, I downloaded the packages specified at
http://www.physics.wustl.edu/~alford/tex/japanese_latex.html including
cjk-latex, hbf-kanji48, latex-cjk-japanese and
latex-cjk-japanese-wadalab.  And I included the same \usepackage
commands, and even used the provided templates.  And running "latex" or
"pdflatex" with a JIS or Shift-JIS file showed the same output as on
that page.  But latex ignored the Japanese, just treating it as a few
broken Roman characters to lay out, e.g. throwing errors when it
encountered an _ character.
Perhaps you can try "sjislatex yourfile.tex" on the SJIS tex source file. You can also take a look at the examples directory in the cjk installation.

Okay, I tried cjk-write-file and sjislatex, with the examples and with
my own files, and it always stops with something like:

% sjislatex japanese_template.tex
This is pdfeTeX, Version 3.141592-1.21a-2.2 (Web2C 7.5.4)
entering extended mode
LaTeX2e <2003/12/01>
Babel <v3.8d> and hyphenation patterns for american, french, german, ngerman, b
ahasa, basque, bulgarian, catalan, croatian, czech, danish, dutch, esperanto, e
stonian, finnish, greek, icelandic, irish, italian, latin, magyar, norsk, polis
h, portuges, romanian, russian, serbian, slovak, slovene, spanish, swedish, tur
kish, ukrainian, nohyphenation, loaded.
Document Class: article 2004/02/16 v1.4f Standard LaTeX document class
(/usr/share/texmf/tex/latex/CJK/CJK.enc))) (./japanese_template.aux)
! Undefined control sequence.
\mule@� ...ber `�\endcsname {#1}\CJK@ignorespaces

l.17 ^^?�^^?177^^?
                  ^^?�^^?234^^?^^?�^^?205^^? ^^?�^^?250^^?^^?�^^?123^^?^^?�^...


I've tried a lot of variations of templates, load options, ways to
indicate that a file is sjis, etc. and nothing seems to work.

This is very frustrating. :-(

Yes, indeed.

I guess it's because japanese_template.tex is written in sjis using emacs which has its own Japanese input method. Therefore, it has to be converted *inside* emacs. I downloaded the (converted) japanese_template.cjk from the web page and "latex japanese_template.cjk" and "pdflatex japanese_template.cjk" produced the right output. I'm ignorant about emacs, unfortunately. I don't use it.

I don't write Japanese very often but when I have to, I use gedit with LC_CTYPE set to ja_JP.eucjp. (My default locale is en_US.utf8). I have this
	alias eucgedit="LC_CTYPE=ja_JP.eucjp gedit"
in my .bashrc to call gedit. I can then simply use latex or pdflatex to compile the latex source. I use scim + anthy as input method. All packages are installed via apt-get.

AFAIK, ja_JP.sjis is not provided out of the box in debian.


Reply to: