[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Audio sparito su SID



D: [pulseaudio][daemon/main.c:919 main()] Found 4 CPUs.
I: [pulseaudio][daemon/main.c:921 main()] Page size is 4096 bytes
D: [pulseaudio][daemon/main.c:926 main()] Compiled with Valgrind support: no
D: [pulseaudio][daemon/main.c:929 main()] Running in valgrind mode: no
D: [pulseaudio][daemon/main.c:931 main()] Running in VM: no
D: [pulseaudio][daemon/main.c:934 main()] Optimized build: yes
D: [pulseaudio][daemon/main.c:942 main()] FASTPATH defined, only fast path asserts disabled.
I: [pulseaudio][daemon/main.c:951 main()] Machine ID is 8ea3c08b08026628314acfb5509bff17.
I: [pulseaudio][daemon/main.c:955 main()] Session ID is 3.
I: [pulseaudio][daemon/main.c:961 main()] Using runtime directory /var/run/pulse.
I: [pulseaudio][daemon/main.c:966 main()] Using state directory /var/lib/pulse.
I: [pulseaudio][daemon/main.c:969 main()] Using modules directory /usr/lib/pulse-11.1/modules.
I: [pulseaudio][daemon/main.c:971 main()] Running in system mode: yes
W: [pulseaudio][daemon/main.c:975 main()] PulseAudio è in esecuzione in modalità sistema. Assicurarsi che sia esattament
e ciò che si desidera fare.
W: [pulseaudio][daemon/main.c:975 main()] Consultare http://www.freedesktop.org/wiki/Software/PulseAudio/Documentation/U
ser/WhatIsWrongWithSystemWide/ per maggiori informazioni sul perché la modalità sistema è una pessima idea.

Ho consultato il link proposto, ma non è spiegato come eseguire PulseAudio in modalità NON system wide...


Il giorno gio 21 giu 2018 alle ore 23:06 Gabriele Stilli <superenzima@libero.it> ha scritto:
Il 21/06/2018 20:03, Davide Prina ha scritto:

> # pulseaudio --system -vvvv --log-meta

Non mi sembra di vederci granché, ma ditemi anche voi:

W: [pulseaudio][daemon/main.c:712 main()] In esecuzione in modalità
sistema, ma --disallow-exit non impostato.
W: [pulseaudio][daemon/main.c:715 main()] In esecuzione in modalità
sistema, ma --disallow-module-loading non impostato.
N: [pulseaudio][daemon/main.c:718 main()] In esecuzione in modalità
sistema, disabilitata in modo forzato la modalità SHM.
N: [pulseaudio][daemon/main.c:723 main()] In esecuzione in modalità
sistema, disabilitato in modo forzato il tempo di uscita per inattività.
D: [pulseaudio][pulsecore/core-rtclock.c:164
pa_rtclock_hrtimer_enable()] Timer slack is set to 50 us.
D: [pulseaudio][pulsecore/core-util.c:861 set_nice()] setpriority() worked.
I: [pulseaudio][pulsecore/core-util.c:905 pa_raise_priority()]
Successfully gained nice level -11.
I: [pulseaudio][daemon/main.c:171 change_user()] Found user 'pulse' (UID
111) and group 'pulse' (GID 120).
I: [pulseaudio][daemon/main.c:247 change_user()] Successfully changed
user to "pulse".
I: [pulseaudio][daemon/main.c:907 main()] This is PulseAudio 11.1
D: [pulseaudio][daemon/main.c:908 main()] Compilation host:
x86_64-pc-linux-gnu
D: [pulseaudio][daemon/main.c:909 main()] Compilation CFLAGS: -g -O2
-fdebug-prefix-map=/build/pulseaudio-5tByER/pulseaudio-11.1=.
-fstack-protector-strong -Wformat -Werror=format-security -Wall -W
-Wextra -pipe -Wno-long-long -Wno-overlength-strings
-Wunsafe-loop-optimizations -Wundef -Wformat=2 -Wlogical-op
-Wsign-compare -Wformat-security -Wmissing-include-dirs
-Wformat-nonliteral -Wpointer-arith -Winit-self
-Wdeclaration-after-statement -Wfloat-equal -Wmissing-prototypes
-Wredundant-decls -Wmissing-declarations -Wmissing-noreturn -Wshadow
-Wendif-labels -Wcast-align -Wstrict-aliasing -Wwrite-strings
-Wno-unused-parameter -ffast-math -fno-common -fdiagnostics-show-option
-fdiagnostics-color=auto
D: [pulseaudio][daemon/main.c:916 main()] Running on host: Linux x86_64
4.16.0-2-amd64 #1 SMP Debian 4.16.12-1 (2018-05-27)
D: [pulseaudio][daemon/main.c:919 main()] Found 4 CPUs.
I: [pulseaudio][daemon/main.c:921 main()] Page size is 4096 bytes
D: [pulseaudio][daemon/main.c:926 main()] Compiled with Valgrind support: no
D: [pulseaudio][daemon/main.c:929 main()] Running in valgrind mode: no
D: [pulseaudio][daemon/main.c:931 main()] Running in VM: no
D: [pulseaudio][daemon/main.c:934 main()] Optimized build: yes
D: [pulseaudio][daemon/main.c:942 main()] FASTPATH defined, only fast
path asserts disabled.
I: [pulseaudio][daemon/main.c:951 main()] Machine ID is
abf996ace268424d91aec34b105f9988.
I: [pulseaudio][daemon/main.c:955 main()] Session ID is 2.
I: [pulseaudio][daemon/main.c:961 main()] Using runtime directory
/var/run/pulse.
I: [pulseaudio][daemon/main.c:966 main()] Using state directory
/var/lib/pulse.
I: [pulseaudio][daemon/main.c:969 main()] Using modules directory
/usr/lib/pulse-11.1/modules.
I: [pulseaudio][daemon/main.c:971 main()] Running in system mode: yes
W: [pulseaudio][daemon/main.c:975 main()] PulseAudio è in esecuzione in
modalità sistema. Assicurarsi che sia esattamente ciò che si desidera fare.
W: [pulseaudio][daemon/main.c:975 main()] Consultare
http://www.freedesktop.org/wiki/Software/PulseAudio/Documentation/User/WhatIsWrongWithSystemWide/
per maggiori informazioni sul perché la modalità sistema è una pessima idea.
I: [pulseaudio][daemon/main.c:1000 main()] System supports high
resolution timers
D: [pulseaudio][pulsecore/memblock.c:859 pa_mempool_new()] Using private
memory pool with 1024 slots of size 64,0 KiB each, total size is 64,0
MiB, maximum usable slot size is 65472
I: [pulseaudio][pulsecore/cpu-x86.c:111 pa_cpu_get_x86_flags()] CPU
flags: CMOV MMX SSE SSE2 SSE3 SSSE3 SSE4_1 SSE4_2
I: [pulseaudio][pulsecore/svolume_mmx.c:246 pa_volume_func_init_mmx()]
Initialising MMX optimized volume functions.
I: [pulseaudio][pulsecore/remap_mmx.c:147 pa_remap_func_init_mmx()]
Initialising MMX optimized remappers.
I: [pulseaudio][pulsecore/svolume_sse.c:257 pa_volume_func_init_sse()]
Initialising SSE2 optimized volume functions.
I: [pulseaudio][pulsecore/remap_sse.c:146 pa_remap_func_init_sse()]
Initialising SSE2 optimized remappers.
I: [pulseaudio][pulsecore/sconv_sse.c:167 pa_convert_func_init_sse()]
Initialising SSE2 optimized conversions.
I: [pulseaudio][pulsecore/svolume_orc.c:46 pa_volume_func_init_orc()]
Initialising ORC optimized volume functions.
D: [pulseaudio][pulsecore/module.c:75 pa_module_exists()] Checking for
existence of '/usr/lib/pulse-11.1/modules/module-udev-detect.so': success
D: [pulseaudio][modules/module-udev-detect.c:290 verify_access()]
/dev/snd/controlC0 is accessible: yes
D: [pulseaudio][modules/module-udev-detect.c:310 verify_access()]
/devices/pci0000:00/0000:00:1b.0/sound/card0 is busy: yes
I: [pulseaudio][modules/module-udev-detect.c:795
module_udev_detect_LTX_pa__init()] Found 1 cards.
I: [pulseaudio][pulsecore/module.c:185 pa_module_load()] Loaded
"module-udev-detect" (index: #0; argument: "").
D: [pulseaudio][pulsecore/module.c:75 pa_module_exists()] Checking for
existence of
'/usr/lib/pulse-11.1/modules/module-esound-protocol-unix.so': failure
I: [pulseaudio][pulsecore/module.c:185 pa_module_load()] Loaded
"module-native-protocol-unix" (index: #1; argument: "").
D: [pulseaudio][pulsecore/database-tdb.c:108 pa_database_open()] Opened
TDB database
'/var/lib/pulse/abf996ace268424d91aec34b105f9988-stream-volumes.tdb'
I: [pulseaudio][modules/module-stream-restore.c:2480
module_stream_restore_LTX_pa__init()] Successfully opened database file
'/var/lib/pulse/abf996ace268424d91aec34b105f9988-stream-volumes'.
D: [pulseaudio][pulsecore/protocol-dbus.c:797
pa_dbus_protocol_add_interface()] Interface
org.PulseAudio.Ext.StreamRestore1 added for object
/org/pulseaudio/stream_restore1
I: [pulseaudio][pulsecore/module.c:185 pa_module_load()] Loaded
"module-stream-restore" (index: #2; argument: "").
D: [pulseaudio][pulsecore/database-tdb.c:108 pa_database_open()] Opened
TDB database
'/var/lib/pulse/abf996ace268424d91aec34b105f9988-device-volumes.tdb'
I: [pulseaudio][modules/module-device-restore.c:1266
module_device_restore_LTX_pa__init()] Successfully opened database file
'/var/lib/pulse/abf996ace268424d91aec34b105f9988-device-volumes'.
I: [pulseaudio][pulsecore/module.c:185 pa_module_load()] Loaded
"module-device-restore" (index: #3; argument: "").
I: [pulseaudio][modules/module-default-device-restore.c:69 load()] No
previous default sink setting, ignoring.
I: [pulseaudio][modules/module-default-device-restore.c:90 load()] No
previous default source setting, ignoring.
I: [pulseaudio][pulsecore/module.c:185 pa_module_load()] Loaded
"module-default-device-restore" (index: #4; argument: "").
I: [pulseaudio][pulsecore/module.c:185 pa_module_load()] Loaded
"module-rescue-streams" (index: #5; argument: "").
D: [pulseaudio][modules/module-always-sink.c:77
load_null_sink_if_needed()] Autoloading null-sink as no other sinks
detected.
I: [pulseaudio][pulsecore/sink.c:362 pa_sink_new()] Created sink 0
"auto_null" with sample spec s16le ch 2 44100 Hz and channel map
front-left,front-right
I: [pulseaudio][pulsecore/sink.c:362 pa_sink_new()]
device.description = "Uscita dummy"
I: [pulseaudio][pulsecore/sink.c:362 pa_sink_new()]     device.class =
"abstract"
I: [pulseaudio][pulsecore/sink.c:362 pa_sink_new()]     device.icon_name
= "audio-card"
I: [pulseaudio][pulsecore/source.c:347 pa_source_new()] Created source 0
"auto_null.monitor" with sample spec s16le ch 2 44100 Hz and channel map
front-left,front-right
I: [pulseaudio][pulsecore/source.c:347 pa_source_new()]
device.description = "Monitor of Uscita dummy"
I: [pulseaudio][pulsecore/source.c:347 pa_source_new()]     device.class
= "monitor"
I: [pulseaudio][pulsecore/source.c:347 pa_source_new()]
device.icon_name = "audio-input-microphone"
D: [null-sink][modules/module-null-sink.c:203 thread_func()] Thread
starting up
I: [pulseaudio][pulsecore/core.c:424 pa_core_update_default_source()]
default_source: (unset) -> auto_null.monitor
D: [pulseaudio][modules/module-device-restore.c:854
sink_put_hook_callback()] Could not set format on sink auto_null
I: [pulseaudio][pulsecore/core.c:337 pa_core_update_default_sink()]
default_sink: (unset) -> auto_null
D: [pulseaudio][pulsecore/core-subscribe.c:242 pa_subscription_post()]
Dropped redundant event due to change event.
I: [pulseaudio][pulsecore/module.c:185 pa_module_load()] Loaded
"module-null-sink" (index: #7; argument: "sink_name=auto_null
sink_properties='device.description="Uscita dummy"'").
I: [pulseaudio][pulsecore/module.c:185 pa_module_load()] Loaded
"module-always-sink" (index: #6; argument: "").
D: [pulseaudio][modules/module-suspend-on-idle.c:93 restart()] Sink
auto_null becomes idle, timeout in 5 seconds.
I: [pulseaudio][pulsecore/module.c:185 pa_module_load()] Loaded
"module-suspend-on-idle" (index: #8; argument: "").
I: [pulseaudio][pulsecore/module.c:185 pa_module_load()] Loaded
"module-position-event-sounds" (index: #9; argument: "").
D: [pulseaudio][pulsecore/dbus-util.c:288 pa_dbus_wrap_connection_new()]
Successfully connected to D-Bus system bus
35fe636e26c8752a2e13cc205b2b75c7 as :1.127
D: [pulseaudio][daemon/main.c:348 register_dbus_name()] Got
org.pulseaudio.Server!
I: [pulseaudio][daemon/main.c:1135 main()] Daemon startup complete.
I: [pulseaudio][modules/module-suspend-on-idle.c:71 timeout_cb()] Sink
auto_null idle for too long, suspending ...
D: [pulseaudio][pulsecore/sink.c:879 pa_sink_suspend()] Suspend cause of
sink auto_null is 0x0004, suspending
D: [pulseaudio][pulsecore/core.c:466 pa_core_maybe_vacuum()] Hmm, no
streams around, trying to vacuum.

> # apt install apt-show-versions
> $ apt-show-versions | grep availa

Nulla di rilevante, mi pare: tutta roba che non gira o non usa l'audio
(e che comunque c'era già da prima, quando tutto funzionava).

android-sdk-platform-tools-common:all 24.0.0+8 installed: No available
version in archive
anki:all 2.1.0+dfsg~b38-1 installed: No available version in archive
eboard:amd64 1.1.1-6.1+b1 installed: No available version in archive
ekiga:amd64 4.0.1-8 installed: No available version in archive
gcj-6-jre-lib:all 6.4.0-12 installed: No available version in archive
libgcj-common:all 1:6.4-3d1 installed: No available version in archive
libgcj17:amd64 6.4.0-12 installed: No available version in archive
libopal3.10.10:amd64 3.10.10~dfsg2-2.1 installed: No available version
in archive
libpt2.10.11:amd64 2.10.11~dfsg-2.1 installed: No available version in
archive
libx264-148:amd64 2:0.148.2795+gitaaa9aa8-1 installed: No available
version in archive
muse:amd64 2.1.2-3+b1 installed: No available version in archive
pdftk:amd64 2.02-4+b2 installed: No available version in archive

> # apt -f install

Niente.

> $ fuser /dev/snd/*

Niente.

Grazie!

Gabriele :-)


Reply to: