[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

[Sid] Xorg e Radeon 9550



Ciao a tutti,

torno a sottoporvi un problema antipatico che ho col pc al lavoro su cui 
ho messo, ormai quasi 2 mesi fa, una fiammante sid.

Nel suddetto pc ho una bella Ati Radeon 9550, che lspci vede come:

0000:01:00.0 VGA compatible controller: ATI Technologies Inc RV350 AS 
[Radeon 9550]
0000:01:00.1 Display controller: ATI Technologies Inc RV350 ?? [Radeon 
9550] (Secondary)

Il fatto è che se in xorg.conf metto "ati" come driver, X non parte e mi 
si blocca il pc: devo accedervi da remoto e riavviare, dopo aver 
rimesso "vesa" come driver, l'unico che funzica (anche con xorg 7.0, 
aggiornato oggi).

Con top vedo che X balza furibondo al 99% e lì sta, e non c'è verso di 
ammazzare i processi: al 99% rimane.

Al che ho pensato che fosse un problema di kernel (che aggiorno tutte le 
volte che apt me lo propone, ora sono con un linux-image-2.6.16-1-k7           
2.6.16-10), ed infatti con un bel lsmod scorgo:

[root@trane:~]# lsmod | grep agp
amd64_agp              11652  1
agpgart                   29296  1 amd64_agp

E secondo me è lì che sta la quistione, dato che io non ho un amd64, ma 
un semplicerrimo sempron 2600.

Dopo essere uscito da X e aver chiuso anche gdm, ho provato a rimuovere 
quel modulo (e magari a mettere quello per l'ati), ma  mi dice sempre 
che "il modulo è in uso e non si può rimuovere".

Che mi consigliate di fare?

PS
al di là che non voglio usare driver proprietari, ho cmq provato la roba 
dell'ati, ma il risultato è il medesimo.

-- 
I videogame  non influenzano  i bambini: infatti  se da  piccoli fossimo
stati  plagiati  da  Pac-man,  adesso   passeremo  il  nostro  tempo  in
ambienti semibui, mangiando pillole  magiche, ed ascoltando della musica
elettronica ripetitiva.		    Kristian Wilson, Nintendo Inc., 1989



Reply to: