[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: strano errore in /var/log/messages



On Thu, 19 May 2005 09:39:01 +0200
Umberto Genovese <umberto.genovese@virgilio.it> wrote:

> Il mercoledì, 18 maggio, 2005 at 09:58:44 +0200, Luigi Curzi Scrisse:
> 
> >   1) qual' e' l'opzione nel kernel?? intanto do un'occhiata se a me
> >   funge...
> >   2) cmq l'errore mi si presenta anche se inserisco un supporto nel
> >   drive...
> >   
> L'upzione è:
> Use multi-mode by default (IDEDISK_MULTI_MODE)
> 
> If you get this error, try to say Y here:
> 
> hda: set_multmode: status=0x51 { DriveReady SeekComplete Error }
> hda: set_multmode: error=0x04 { DriveStatusError }
> 
> If in doubt, say N.
> 
> #
> # ATA/ATAPI/MFM/RLL support
> #
> CONFIG_IDE=y
> CONFIG_BLK_DEV_IDE=y
> 
> #
> # Please see Documentation/ide.txt for help/info on IDE drives
> #
> # CONFIG_BLK_DEV_IDE_SATA is not set
> # CONFIG_BLK_DEV_HD_IDE is not set
> CONFIG_BLK_DEV_IDEDISK=y
> CONFIG_IDEDISK_MULTI_MODE=y
> CONFIG_BLK_DEV_IDECD=y
> # CONFIG_BLK_DEV_IDETAPE is not set
> CONFIG_BLK_DEV_IDEFLOPPY=m
> CONFIG_BLK_DEV_IDESCSI=y
> CONFIG_IDE_TASK_IOCTL=y
> 
> 
> Comunque, se ho ben compreso, il problema è dovuto dai firmware dei
> drives: alcuni sparano fuori dei controlli ciclici a vuoto che il
> kernel normalmente non gestisce e altri firmware no. 
> Ora vorrei guardare le opzioni che si possono passare al modulo ide-cd
> per vedere se si può fare qualcsa, ma dovrò ricompilare il kernel per
> questo. Ma usi hal? 
> ps ax | grep hald 
> cosa dice quando hai tutto impallato?
> 
> 
> -- 
>      Ciao Umberto

sia se uso o non uso hal l'errore compare in messages.
inoltre quell'opzione del kernel l'ho provata svariate volte in
combinazione con altre, ma non ha risolto il problema.
ma il problema comunque non è solo questo.
come ho detto nella prima mail, per masterizzare ad una velocità
accettabile i dvd(> 0.4x) devo re-installare il modulo ide-cd ad ogni
riavvio. inoltre questo problema mi sembri si presenti solo con dvd-r/rw
e con i cd (che dovrebbero essere masterizzati a 40x ed invece vengono
bruciati a solo 16x).
ma non solo ho avuto anche problemi con il dma DEL 2° HARD DISK (HDB)
che mi veniva impostato a udma2 quando in verità doveva essere udma4. ho
risolto quest'ultimo inconveniente togliendo alcuni moduli dal kernel.
cmq, innanzitutto grazie per l'interessamento, secondo te non potrebbe
dipendere da una disposizione hardware non adatta?
io ho i due harddisk sullo stesso canale ide e i due
lettori/masterizzatori sull'altro, se cambiassi disposizione e mettessi
i due harddisk come master su i due canali ide e i lettori com slave?
non lo so, io sparo a caso, ma siccome questi problemi con la scheda
madre precedente non li avevo...

cmq quello che ottengo dal comando che mi hai detto è:

luigi@vucinet:~$ ps ax | grep hald
 4453 ?        Ss     0:50 /usr/sbin/hald --drop-privileges
27372 pts/2    S+     0:00 grep hald

alcune informazioni: ho una scheda madre asus p4p800-f con chipset
ich5.

ciao
e ancora grazie

Luigi



Reply to: