[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

tomcat problems

Hi all,

I'm having a helluva time getting tomcat to work on woody w/apache 1.3. i've got tomcat 4 installed, IBM sdk installed and symlinked in /usr/local/ to /usr/local/java. it looked like tomcat may have been reaching the kaffe java packages, so i changed all the java related packages in /etc/alternatives to point to the new location. I go to start tomcat with the init.d script, and it doesn't error out, but nothing gets started. i've tried exporting JAVA_HOME via bash, then running /usr/share/tomcat4/bin/start.sh and that launches a catalina start script, but nothing else:

host:~# set |grep -i java

host:~# /usr/share/tomcat4/bin/startup.sh
Using CATALINA_BASE:   /usr/share/tomcat4
Using CATALINA_HOME:   /usr/share/tomcat4
Using CATALINA_TMPDIR: /usr/share/tomcat4/temp
Using JAVA_HOME:       /usr/local/IBMJava2-ppc-142

host:~# ps aux | grep tom
root 31969 0.0 0.1 3244 1464 pts/0 S 14:26 0:00 /bin/sh /usr/share/tomcat4/bin/catalina.sh start

I've done a good amount of googling for tutorials and howto's which all seem fairly similar, and pretty straight foward, though nothing i've tried is working.

can anyone suggest a good known working tutorial or howto for making this work?

also, i'm using debian on a xserver powerpc architecture which could be the problem (???), hence the reason i'm using IBM's sdk and not Sun's.

any insight appreciated, i'm not sure where to go at this point, and i need to get this setup asap.


Reply to: