[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Exim from source

Craig wrote:

I have compiled the exim 4.20 from source and would like to install it
on my deb box, however it already has the version that comes with woody installed and I cannot remove it because of dependancy problems.

One way to do it is to use the equivs package, which is basically a fake package that lies to dpkg and satisfies dependencies.

The APT HOWTO at http://www.debian.org/doc/manuals/apt-howto/ch-helpers.en.html describes how to use it, and even uses an MTA as the example case.

Note, however, that the package information page at http://packages.debian.org/stable/admin/equivs.html uses language like "crude hack" to describe itself.

If there's Debian packaging information for 4.20, I'd strongly recommend just building a new Debian package file and installing /it/ instead.

Asher Densmore-Lynn <jesdynf@almostcosmic.com>

Reply to: