[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

apt-get dist-upgrade problem

I have a wierd error from when I tried to upgrade a system from stable/woody (a
few sarge packages like snort) to SID.

I understand SID is a bit unstable (thus Still in Development)...
Any ideas what could be causing /usr/bin/du to be undeletable? I can't write a C
program to delete it, I can't delete it by hand, etc.. I can't even move it to a
different file (which i normally can do if a process has a lock on a file handle).

Any suggestions appriciated.  PLEASE CC: me on all replies!



# apt-get dist-upgrade
Reading Package Lists... Done
Building Dependency Tree... Done
Calculating Upgrade... Done
The following NEW packages will be installed:
  cpp-3.2 dictionaries-common g++-3.2 gcc-3.2 gcc-3.2-base gettext
libasn1-6-heimdal libcomerr1-kerberos4kth libdb4.1 libdns8 libgd2-noxpm
  libgd2-noxpm-dev libglib2.0-0 libidn9 libkrb-1-kerberos4kth libkrb5-17-heimdal
libpaper-utils libpaper1 libpcap0.7 libperl5.8 libpng12-0
  libpng3 libpq3 libroken16-kerberos4kth libsnmp5 libssl0.9.7 libstdc++5
libstdc++5-dev po-debconf python2.2 python2.2-optik 
The following packages have been kept back
165 packages upgraded, 31 newly installed, 0 to remove and 1  not upgraded.
7 packages not fully installed or removed.
Need to get 0B/97.3MB of archives. After unpacking 76.5MB will be used.
Do you want to continue? [Y/n] 
Preconfiguring packages ...
(Reading database ... 27942 files and directories currently installed.)
Preparing to replace coreutils 4.5.2-1 (using .../coreutils_4.5.10-1_i386.deb) ...
Unpacking replacement coreutils ...
Replacing files in old package debianutils ...
dpkg: error processing /var/cache/apt/archives/coreutils_4.5.10-1_i386.deb
 unable to make backup link of `./usr/bin/du' before installing new version:
Operation not permitted
dpkg-deb: subprocess paste killed by signal (Broken pipe)
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)

Reply to: