[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Problem with RAID1 on kernel 2.4

On Tue, 26 Feb 2002 10:41, I. Forbes wrote:
> 1)  The initrd is massive about 3mB, I hope that means I will always
>     have all the modules I will ever need at boot time, and I assume
>     the RAM is freed up by the time the system is running.  I
>     increased the size of my boot partition to 15 mB, but otherwise
>     this is not really a problem.

I've posted to debian-devel about how to solve this.  Let me know if you 
can't find my posting in the archives and I'll dig it out again.

Basically I've got 1M compressed initrd's even with a 1M SE Linux policy 
database (it's 3M uncompressed including the policy database).

The main problem here is the libc is big (and busybox-static doesn't work 

>     Notwithstanding the above, I put a long list of modules in both
>     /etc/modules and /etc/mkinitrd/modules.  (ide stuff, md, raid1,
>     ext2 ext3 etc), I am not sure how much of this was necessary.

You definately don't want both ext2 and ext3.

> 2)  Then I had endless problems with raid1.  It seems that the
>     "failed-disk" directive in /etc/raidtab does not work.  I think
>     it has something to do with devfs - which is compiled into the
>     standard "woody" 2.4 kernel.

No.  failed-disk has always worked fine for me with devfs.

>     proc/mdstat shows the drives with their devfs names not the old
>     /dev/hd.. names.

When you compile devfs into the kernel most things will report the devfs 

>     I tried installing debian's devfsd package but did not solve
>     the problem.  Maybe there is some clever customization required
>     to make it work.

devfsd only creates compatibility symlinks and changes permissions when devfs 
is mounted.  When devfs is not mounted and if you configure devfsd to not 
mount it automatically then devfsd will exit silently.  If you don't rely on 
compatibility symlinks and you are running as root then devfsd does not do 
anything you really NEED anyway.

>     Putting the full devfs names into /etc/raidtab did not work.
>     Maybe I did not have everything setup correctly or I got the
>     names wrong.  I could not find any devfs devices in the /dev
>     directory.

So devfs is not mounted, so you just use the old style names.

> I am not sure how much is related to the chipset, or whether this is a
> known issue with kernel 2.4.  In hindsight, I should have compiled a
> new kernel without initrd or devfs and made all the raid and ide
> modules built in.  I actually tried this but after two or three
> compilations without getting a kernel with the right configuration, I
> thought doing it the other way might be faster.
> Has anybody else been down this road yet?

Yes.  I've posted a number of messages in debian-{isp,devel} about what I've 
done.  I've got everything you list working to my satisfaction.

It's not all documented and it's not all easy, but it's all possible.

Signatures >4 lines are rude.  If you send email to me or to a mailing list
that I am subscribed to which has >4 lines of legalistic junk at the end
then you are specifically authorizing me to do whatever I wish with the
message (the sig won't be read).

Reply to: