[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Newbie problem with mon

On Mon, 3 Sep 2001, Nicolas Bouthors wrote:

> Looking at the doc, I see that I need the perl module SNMP, but when I try to 
> install it (with 'perl -MCPAN -e shell' or from the tar.gz) the build process 
> crashes lacking a #ldefine TYPE_INTEGER32 and a few others.
> I'm sure it's a very simple problem with a very simple solution, but I don't 
> see where is my mistake.
> Any help apreciated,
> 	Nico
> PS : Packages installed : libsnmp4.1, libsnmp4.1-dev, snmpd

often marzot's perl module is closely linked to the version of ucd-snmp
(now called net-snmp). it would be a good experiment to install the latest
code from http://net-snmp.sourceforge.net/ and use the perl module which
comes with that. i don't keep track of debian packages, but you may be
able to find a pre-packaged version of the ucd tools + the perl module.

the perl snmp module is only needed if you want to use the monitors
which communicate with the monitored devices using snmp, i.e. it is not
necessarily required for mon itself.

Reply to: