[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: apache_1.3.12 SSL error



On Thu, Jun 29, 2000 at 05:34:40PM +0200, Dariush Pietrzak wrote:
> 
> > mod_ssl module (I think that's what you asked the first time).  Does
> > it not work for you?
> 
> It doesen't:
> 
> apt-get install apache-perl libapache-asp-perl Reading Package Lists... 
> Done Building Dependency Tree... Done The following packages will be
> REMOVED: 
>   apache libapache-mod-ssl The following NEW packages will be installed: 
>   apache-perl libapache-asp-perl
> 
> is there something wrong with dependencies? or maybe there's some reason
> for that situation?

Ok, here's the deal ... libapache-mod-ssl depends on apache, and even
though apache-perl provides apache the dependency isn't satisfied.  i
think that's because the apache dependency is version specific, but
that's a guess.  IANADD.

I compiled my own libapache-mod-ssl package and editted the
"Depends:" line in the debian/control file.

I changed this:

  Depends: ${shlibs:Depends}, openssl, apache (>= 1.3.9-1), apache (<= 1.3.9-99), make

to this:

  Depends: ${shlibs:Depends}, openssl, apache (>= 1.3.9-1) | apache-perl (>= 1.3.9-1), apache (<= 1.3.9-99) | apache-perl (<= 1.3.9-13.1-1.21.20000309-1), make

Ugly, but it installs.  You need apache-dev and libssl09-dev from
potato.

-- 
Nathan Norman         "Eschew Obfuscation"          Network Engineer
GPG Key ID 1024D/51F98BB7            http://home.midco.net/~nnorman/
Key fingerprint = C5F4 A147 416C E0BF AB73  8BEF F0C8 255C 51F9 8BB7

Attachment: pgpVPr0ofP4Pw.pgp
Description: PGP signature


Reply to: