[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Upgrade failed

Problem solved..... found answer in archives (file attached)

many thanks to those who tried to help


On Wed, Feb 23, 2000 at 10:27:34PM -0600, Alberto Brealey G. wrote:
> i've done a fresh install of slink (because i have the bootable CD lying
> around...), and need to upgrade to potato/frozen. it does the apt-get update
> fine (retrieves the package lists). when i try to dist-upgrade, it downloads
> 13.7 MB fine, but when trying to install, it exits with:
> E: Internal error, couldn't configure a pre-depend
> does anyone knows what might be wrong? (I tried different mirrors on my
> sources.list, they all did the same).

It's a circular pre-depends.  I'm appending my previous email on the
subject.  I've seen a few posts that say my method works, but I still
don't guarantee it :)

Nathan Norman                                       Network Engineer
GPG Key ID 1024D/51F98BB7                       "Eschew Obfuscation"
Key fingerprint = C5F4 A147 416C E0BF AB73  8BEF F0C8 255C 51F9 8BB7

On Tue, Feb 22, 2000 at 11:37:13AM -0700, john s anderson wrote:
[ snip ]
> However, I'd like to update the installation to at least frozen, and
> probably to unstable -- and that's where the problem comes in. After doing
> the base install, I add the frozen line to sources.list, do `apt-get
> update` -- all of which works as expected.
> Any attempt to install pretty much anything after that won't work, because
> of some problem between debianutils and libc6. It looks to me like they're
>  mutually pre-dependent, or something. Here's the error output from
> `apt-get install libc6`:
> <output>
> penguin:~# apt-get install libc6
> Reading Package Lists... Done
> Building Dependency Tree... Done
> The following extra packages will be installed:
>   g++ libstdc++2.10 cpp gcc debianutils libc6-dev libstdc++2.10-dev
> binutils
>   ldso
> The following packages will be REMOVED:
>   timezones libstdc++2.9-dev egcc
> The following NEW packages will be installed:
>   libstdc++2.10 libstdc++2.10-dev
> 8 packages upgraded, 2 newly installed, 3 to remove and 582 not upgraded.
> Need to get 0B/7390kB of archives. After unpacking 9989kB will be used.
> Do you want to continue? [Y/n]
> E: Internal Error, Couldn't configure a pre-depend
> </output>

I was able to get around this, but I DO NOT recommend that anyone use
my method!!  If you do, don't tell me about how screwed up your system

Ok, it appears that libc6 predepends on a version of debianutils that
provides "readlink".  debianutils predepends on a version of libc6 >=
2.1 ... catch-22.  However, a *brief* glance at the libc6 pre-inst
indicates that readlink is being used to preserve time zone
configuration info.

I decided that breaking time zones was not a big deal.  Of course,
this particular machine is not mission critical, so I must stress
again that this worked for me, it probably won't work for you.  if it
does, cool.  If not, you've been warned twice :)

I created a file "/usr/bin/readlink" with the following contents:

  #! /bin/sh

I then installed libc6 using a --force-depends (this is your third
warning!  This is not a good idea!)  I found the libc6 deb in
"/var/cache/apt/archives", so I cd over there and type

  dpkg --force-depends -i libc6_2.1.3-4_i386.deb

Directly afterwards I ran apt-get:

  apt-get -f install

Luckily, everything still worked, and I was able to proceed to
`apt-get upgrade', etc.

I'm fairly insane so the above is FYI :)


Nathan Norman                    Network Magician, Eclectic Engineer
GPG Key ID 1024D/51F98BB7                       "Eschew Obfuscation"
Key fingerprint =3D C5F4 A147 416C E0BF AB73  8BEF F0C8 255C 51F9 8BB7

Reply to: