[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

RE: Inetd not listening on IPv6

In article <013901c1308f$60e3c140$0200000a@jornets> (at Wed, 29 Aug 2001 15:34:49 +0200), "Joan Cirer" <j.cirer@barcelo.com> says:

> I tried it and works, but It seems that I can't have the same service
> running on IPv6 and IPv4 and the sametime...
> I copied and psted a line for an internal service (time tcp) and changed tcp
> for tcp6 and it didn't work, but only having the tcp6 line it worked perfect

> > Could somebody tell me how can I activate inetd with IPv6?
> just replace the "tcp"'s with "tcp6"'s and it works fine ...

Try "tcp46".
The usagi inetd support 4 different configurations on a single port.

 1."tcp4" (or "tcp") only 
    -> ipv4 only
 2."tcp6" only
    -> ipv6 only (not ipv4)
 3."tcp46" only
    -> ipv4 and ipv6; ipv4 is served by ipv6 daemon with ipv4-mapped addresses.
 4.both "tcp4" (or "tcp") and "tcp6" at the same port. 
    -> ipv4 and ipv6 will be served by ipv4 daemon and ipv6 daemon 

If you use original kernel, you can not use 4.

BTW, I describe above behavior in inetd.8 like this:

     The protocol must be a valid protocol as given in /etc/protocols. Examュ
     ples might be ``tcp'' or ``udp'', both of which imply IPv4 for backward
     compatibility.  The names ``tcp4'' and ``udp4'' specify IPv4 only.  The
     names ``tcp6'' and ``udp6'' specify IPv6 only; inetd will reject / ignore
     packets from ipv4 clients.  The names ``tcp46'' and ``udp46'' specify
     that the entry accepts both IPv4 and IPv6 connections via a wildcard
     PF_INET6 socket.  Rpc based services are specified with the ``rpc/tcp''
     or ``rpc/udp'' service type.

Isn't that file included in your package, Yamamori-san?


Reply to: