[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Local Admin question

On Sat, 28 Feb 2009, David Given wrote:

Hash: SHA1

[Apologies if you get this twice --- I posted the other copy from the
wrong email account. Hopefully the Debian servers should have rejected
it, but you never know. This one's also slightly updated.]

I have the same problem as the OP --- I'm in Administrators but don't
have access to Administrator --- and tried your suggestion. Using both
tricks I can get a login as uid=197108. However, actually doing the
installation fails.

Note that this is done without any of the hotfixes, because the hotfix
website keeps reporting technical errors when I try to download things.
(Is there an alternate source for these? Preferably a combined patch
with all relevant hotfixes?)

On which OS you are (uname -X)? The hotfixes are most important for SFU 3.5, for the others the SUA components get updated with standard service packs also, so these are not that outdated.

(a) I get failures during debootstrap due to not being able to find
chroot. I added /usr/sbin to my path (which wasn't there by default) and
tried again.

Good point, I'll change the install doc accordingly.

(b) I get more chroot errors:

I: Installing core packages...
W: Failure trying to run: chroot // dpkg --force-depends --install
W: Failure trying to run: chroot // dpkg --force-depends --install

I saw these also, with no ill effect. I think some package priorities have changed over the time, so there are no core packages left after all base packages have been installed. Thus the error.

However, the installation appears to proceed and I can't find anything
in debootstrap.log.

(c) After the unpacking stage I get this:

I: Configuring debconf-english...
W: Failure while configuring base packages.
W: Failure while configuring base packages.
W: Failure while configuring base packages.
W: Failure while configuring base packages.
W: Failure while configuring base packages.
I: Base system installed successfully.

Looking at the debootstrap.log I see lots of dependency errors, mostly
complaining about missing ms-libc3.5.

Ignore the ms-libc3.5 ones. For them is "apt-get install -f".
The others *might* cause problems, but it mostly is something like "chown" which fails. I currently ignore these, I even use a symlink /bin/chown -> /bin/true sometimes, especially with arch:all packages.

Assuming that I now had at least a partial Debian installation, I
proceeded with the next steps to get apt up and running; to my total
surprise, this worked flawlessly, and the upgrade stage installed and
fixed the missing packages.

So I now think I have a working Debian --- which is extremely cool. Is

Congratulations. It should be ok.

there anything I can do to check that the Administrator workaround has
actually worked properly and gotten all the file permissions correct? I

I think everything is ok, dpkg wouldn't have run without being 197108.
For other permission issues: I didn't bother that much on these as I'm mostly using Administrator. The original Debian file permissions should however have been set. Some Debian packages create extra users for them, which currently doesn't work on debian-interix, so there might result some problems because of that.

do notice that after installing openssh-client, it only actually *works*
from Administrator; running it as me produces:

PRIV_END: seteuid: Network is down

Hmm, on SFU 3.5 it works for me, even as normal domain user. You probably are on something newer, are you? Do you try login with password or password-less? (The latter probably won't work.) Is your local and/or remote home drive on a network share?

Incidentally, one minor bug report: the setup script doesn't like being
run from a path containing spaces...

Ok, thanks, at least I'll add it to the install doc.
I think, it's not that easy to fix. :-(


Reply to: