[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Updated installation images for Debian Ports 2019-04-12

Hi Adrian,

much obliged for the ia64 ISOs. :-D

On 4/12/19 11:34, John Paul Adrian Glaubitz wrote:

I just uploaded updated installation images 2019-04-12 for the
following Debian Ports architectures:
  * ia64
Please test those images and report back over the mailing list for
the corresponding architecture.

Known issues:
  * ia64
    - The kernel might be unstable during install
      (try passing "hardened_usercopy=off" at the boot prompt,
       e.g. "install hardened_usercopy=off"

When reporting issues or bugs, please include the syslog
from your installation in the bug report/mail. The log
file can be access when switching to another console using
<Alt>+<Cursor> for normal installations or <Ctrl>+<a>+<n>
when installing over a serial console. I also need to know
what hardware was used, which installation steps (normal
vs. expert) and which image was used.


[1] https://cdimage.debian.org/cdimage/ports/2019-04-12/
[2] https://cdimage.debian.org/cdimage/ports/debian-installer/

I used the 2019-04-12 image ([1]) and tested a normal mode installation
on the following machines with mixed success:


## rx2620 (w/2x Itanium 2 9020 (Montecito) and enabled Hyper-Threading,
HP zx1 chipset) ##

No luck so far

The machine produces a lot of "usercopy: Kernel memory overwrite attempt
detected" errors when the UDEBs are installed. Going back to the menu is
also not possible, as the installer screen exits afterwards. I therefore
also don't have a network connection to copy out the syslog. And I can't
even mount a FS on a USB stick, trying to load the ext3 module gives a
segfault, not sure if it is already available at the start of the
installation. I therefore manually "copied" information from the console
(see attached text file).

I can't continue with the installation from there on.

But as this machine worked well with older kernels, I assume it's either
the newer kernel that's problematic for this machine or the installer
environment or a combination. Though when using the same kernel version
(4.19.28) with a NFS root FS and the "hardened_usercopy=off" kernel
command line option, I don't see any problems even when upgrading nearly
two dozens of packages.

root@rx2620:~# uname -a
Linux rx2620 4.19.0-4-mckinley #1 SMP Debian 4.19.28-2 (2019-03-15) ia64

root@rx2620:~# cat /proc/cmdline
BOOT_IMAGE=net0:/AC100221.vmlinuz  root=/dev/nfs ip=:::::enp32s2f0:dhcp
modprobe.blacklist=radeon hardened_usercopy=off

root@rx2620:~# cat /etc/*release
PRETTY_NAME="Debian GNU/Linux buster/sid"
NAME="Debian GNU/Linux"

I therefore don't assume a hardware failure, even more as the machine
worked flawlessly with Debian GNU/Linux Sid on NFS root FS since about a
year or so.

## rx2660 (w/1x Itanium 2 9140M (Montvale) and enabled Hyper-Threading,
HP zx2 chipset) ##

On this machine I don't see any of these "usercopy: Kernel memory
overwrite attempt detected" as on the rx2620 neither with nor without
the "hardened_usercopy=off" kernel command line option active. Could be
related to the different hardware.

I could perform a successful installation on this machine - with some
manual "help":

* there is no need to load any firmware for the built-in tg3 driven
NICs, although a dialogue in the installer indicates differently

* To be sure to have enough space for two kernels and two initramfs
images on the EFI system partition, increase the sizes in your desired
partman-auto recipe. E.g. for everything on one partition (aka atomic)
change `/lib/partman/recipes-ia64/30atomic` as follows:
538 538 1075 fat16
        $primary{ }

        method{ efi }

        format{ } .

I'm preparing a patch for d-i/partman-auto to include these changes in
the future.

* "bootstrap-base" fails due to:
Apr 14 14:46:39 debootstrap: dpkg: dependency problems prevent
configuration of vim-tiny:
Apr 14 14:46:39 debootstrap:  vim-tiny depends on vim-common (=
2:8.1.0089-1); however:
Apr 14 14:46:39 debootstrap:   Version of vim-common on system is
Apr 14 14:46:39 debootstrap:
Apr 14 14:46:39 debootstrap: dpkg: error processing package vim-tiny
Apr 14 14:46:39 debootstrap:  dependency problems - leaving unconfigured
This can be worked around by modifying the file
`/var/lib/dpkg/info/bootstrap-base.postinst` and adding an
`--exclude=vim-tiny` to the debootstrap command starting at line 147
(see [2] for comparison). You should do this in a shell during the
partitioning step, as the installer will hold there for user input. Some
days earlier I had to also use "apt pinning" to prevent a retried
installation of that package - which also failed - later on in the
installation process. But today this wasn't needed any longer. I hence
assume that the 2019-04-12 installer image still contains the
"incompatible" vim-tiny and vim-common packages, but the ports mirror
does not. Hence I assume this issue will be gone with the next ISO image.


* elilo installation fails as long as the EFI system partition is
mounted. So unmount it before the elilo installation, to make it succeed.

These manual changes should allow you to install Debian GNU/Linux Sid on
your rx2660 or possibly other Itanium machine.

**IMPORTANT:** When installing on an Integrity with MP iLO, before
restarting after the installation has finished, make sure to add
`modprobe.blacklist=radeon` to the kernel command line in the elilo
configuration file on the EFI system partition, i.e. add
`append="modprobe.blacklist=radeon"` to the respective stanza ther, as
otherwise the kernel/machine will hang during kernel boot. This is a
known problem with the MP of these machines and their older HPPA

## rx2800 i2 (w/1x Itanium 9320 (Tukwila) and enabled Hyper-Threading,
Intel Boxboro chipset) ##

No luck so far.

The firmware restarts when the kernel is started and there's no kernel
output. But that was sort of expected, as the only kernels that ever ran
on this machine were the ones based on Gentoo's kernel sources for 4.9.x
and 4.14.x. To be clear, this machine runs with the Debian userland (on
NFS root FS) and a Gentoo kernel - as do my other Integrities with
Debian kernel - the rx2800 i2 is just not installable at the moment.

## rx4640 (w/4 x Itanium 2 1.3 GHz (Madison), HP zx1 chipset) ##

I'll check the installer ISO on this machine tomorrow. Hopefully it
behaves differently than the rx2620.


Attachment: rx2620-kernel-memory-overwrite-detected.txt.gz
Description: application/gzip

Reply to: