[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: DRM/DRI accelerated (3D) graphics?

Apologies for the Spam, but I made a lot of progress on the below:

Built hp-agp into the kernel, not a module
Enabled the fbcon module in the Kernel config
Forceload fbcon module at boot
Set AGP mode to 2 and allowed KMS on

This got me a black screen in the terminal (some sort of unsupported
text mode?) but starting X I can see with KMS enabled I get no AGP bind
errors and no DRM panics. GLXGears/Info confirm DRI and HW acceleration
with R300 working and no corruption! GLXgears is putting out 1925fps.

Now just need to fix the terminal mode!


On 09/18/11 00:38, A. Devine wrote:
> Just to update on the below, after Sending I double-checked if HP AGP
> was actually selected in the Kernal config.. which it wasnt, doh! With
> that on and hp-agp forced to load as a module that bit is ok, but with
> KMS enabled I get no screen and instant beeping error.
> With no KMS I get:
> [   275.231] drmOpenByBusid: drmGetBusid reports pci:0000:80:00.0
> [   275.231] (II) [drm] DRM interface version 1.4
> [   275.231] (II) [drm] Mapping SAREA for DRM lock failed.
> [   275.231] (EE) RADEON(0): [dri] DRIScreenInit failed.  Disabling DRI.
> This is with Emeric's patch on hp-agp , same no matter I think. I think
> Ill try the other AGP card again (above still with R300).
> On 09/17/11 22:42, A. Devine wrote:
>> Hi Emeric,
>> To finally get back onto this, it appears hp-agp is not being loaded as
>> a module (not in lsmod and I have tried manually specifing it in the
>> modules file).
>> I have also tried compiling the kernel with it built in, no difference
>> to results. With the R300 card when KMS is enabled I get a black screen
>> when Gentoo is loaded, with no KMS (radeon modeset=0) I get the terminal
>> but no working AGP (no DRI) due to:
>> Xorg.0.log
>> [  5480.077] (II) [drm] DRM interface version 1.4
>> [  5480.077] (II) [drm] Mapping SAREA for DRM lock failed.
>> [  5480.077] (EE) RADEON(0): [dri] DRIScreenInit failed.  Disabling DRI.
>> AGPGart however is loaded (dmesg |grep agp):
>> IOC: reserving 512Mb of IOVA space at 0x60000000 for agpgart
>> Linux agpgart interface v0.103
>> I get a DRM error in dmesg however:
>> [drm] Initialized radeon 1.33.0 20080528 for 0000:80:00.0 on minor 0
>> [drm:drm_mmap_locked] *ERROR* Could not find map
>> Very odd I get all these problems only with an R300 card though.. as per
>> the earlier note in the thread the RV620 (Radeon HD2500) works much
>> better, though in "PCI mode"?
>> Alan
>> On 09/02/11 13:16, Émeric Maschino wrote:
>>> Hi Alan,
>>>> [drm:radeon_agp_init] *ERROR* Unable to acquire AGP: -19
>>>> This error is always there no matter the patch or not.
>>> Good news at tleast that the patch isn't introducing a new regression.
>>> About this error, did you check that the hp zx1 AGP GART is either
>>> compiled into the kernel or as a module AND loaded into memory (lsmod
>>> | grep hp-agp)?
>>>> More annoyingly I get a corrupted display even in GLXGears with the R300
>>>> (although 700fps) where I was getting perfect image but 400fps on the RV610.
>>>> I cannot understand why the R300 is still getting the corrupted display,
>>>> it got it without any recompiling (which I have done now many times to
>>>> test the above) even when just swapping the cards over (same driver so
>>>> should work).
>>> Is it with current Mesa? I also had screen corruption with my FireGL
>>> X1, but the problem has been fixed by now
>>> (https://bugs.freedesktop.org/show_bug.cgi?id=36608).
>>>      Emeric

Reply to: