[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Kernel panic after kernel update.

Покотиленко Костик wrote:
I have seem this problem on non-ia64 system.

First, check which root partition the kernel is said to use (root=
kernel option).

Then watch the boot process and check how your boot HDD is being
recognized. The most common case is when you try to boot from
root=/dev/hda1, but your HDD is being recognized as, say, /dev/hde1.
I am watching the boot process up to the kernel panic closely but I dont see any HDD line, is it possible that my HDD is not detected soon enough? I has been working for about 2 years now, one year on this debian system.

Which elilo.conf file should I be examining? There is one in the boot partition (efi/debian/elilo.conf this is an msdos/vfat partition) and the other is in root partition (/etc/elilo.conf). They are both pretty much the same. Which one is read at boot time? Which one should I modify?

The root in both the above mentioned files was set to /dev/sda2 right now, and the time stamp on all the files in efi:efi/debian/* (including elilo.conf file) is on the same day (last friday) that I updated the kernel. The /etc/elilo.conf file has time stamp from 11 months back, is it possible that I haven't updated my kernel in a year? since booting used to work before friday!

The root partition when I boot through the debian sarge net install cd (2.6.8-2-itanium-smp) is located at /dev/discs/disc0/part2 ... but both the elilo.conf files have root=/dev/sda2 . I tried changing the root= statement to roo=/dev/discs/disc0/part2 ... but I still get the same error.

Can anyone tell me how should I proceed?

On my system I have two IDE controllers and sometimes their recognition
order is being changed.

I have PATA HDD attached to ICH7 controller and DVD-RW to ITE8211. So,
in normal case I have /dev/hde for my HDD and /dev/hda for DVD-RW. But
sometimes ICH7 driver is being loaded before ITE8211, and I get them
switched: /dev/hda for HDD and /dev/hde for DVD-RW, and I get the same
error as you.

В Вск, 02/07/2006 в 10:14 -0700, Spundun Bhatt пишет:
Can someone please respond to my question over here? This *is* the right forum, isn't it?

Spundun Bhatt wrote:
Hi debian-ia64.

I updated the kernel on my debian linux testing from linux-image-2.6.12-1-mckinley to linux-image-2.6.15-1-mckinley .

When I rebooted, I got the error saying the following (very early in the boot).

RAMDISK: Compressed image found at block 0
Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block (0,0)

I suspect that the new kernel bootloader configuration is pointing to a non-existing location for root partition...

Can anyone guide me as to how to debug this problem?
Also is there any literature available that will help me understand how linux boot loader works on debian on ia64? I mean what are the packages responsible for installing the bootloaders and where can I find the configuration so that I can check whether its right or not, etc?

Thanks a lot


Reply to: