[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: HP i2000 IA64 install experience w/3.1 testing

Thanks for the reply & info, much appreciated.
Replying directly to you in case it is not useful to the boot list & cc'ing to the
IA64 list.

Frans Pop wrote:
On Friday 28 April 2006 15:50, Hurf Sheldon wrote:
After several attempts, Debian 3.1 "testing" was installed successfully
on IA64 HP i2000 Itanium 733mhz single cpu. using the Debian 3.1
netinst.iso. "locale"  errors were a problem on all installations.
Consider this a bug report for the install dialog. Problems were
experienced with earlier Sarge version and various mirrors.

I'm not going to reply to all the installation attempts. I've personally no experience with the IA64 port and don't know about issues with Sarge. Glad though that the current Etch installation worked.

Some of your mirror problems can be explained by the fact that there is a mirror reorganization going on currently and the installer still reflects the "old" situation.
OK - gatech.edu was the only one that was error free but by then we had learned to
keep the selection small.
1: Debian Sarge loaded, we chose "desktop"; the install errored out on
2.6 expert saying several packages didn't download  correctly from the
mirror (debian.lcs.mit.edu)

That is after the reboot then. In that case recovering from the errors should have been possible without having to reinstall. Your problems could be either related to the mirror you were using (in which case switching to a different mirror is pretty easy) or maybe due to architecture specific bugs in aptitude.
We wanted to achieve an error free install to have confidence in the initial platform. After we did, aptitude worked as advertised and was robust enough to use a cdrom
that wasn't labeled specifically. (this could be a feature or a bug)
3: Downloaded debian-testing-ia64-netinst.iso ( "Etch"?) went through
expert load
Was offered only "stable" from ftp.debian.org - (hey, why not?) this

Installing stable using the Etch installer is not really supported.
It was all that was offered from the mirror so we took a chance - It might have worked but
for the locale problems but we don't know.
How to solve "locale issues "  (After some manual surfing & trial &
error): Created /etc/locale.gen with 'echo "en_US UTF-8"
/etc/locale.gen' ran `locale-gen`.

The best way is: 'dpkg-reconfigure locales'
I think this was tried and failed with a "xxx does not exist or not writable" (more or less) error
Should the "Locale" stuff be set by the language dialog during the
install? (Most of the errors were "Couldn't set LC_xxx - file not

Some errors with locales _during_ the installation are expected. However, you should not get any errors after the installation.

What language and country did you select exactly at the beginning of the installation?
US, English and Eastern time. None of these seemed to have been applied as we had to
set date/time/tz by hand (with `date`).
If you installed in expert mode with the Etch installer, did you change any of the defaults in the two questions about locales after that?
What were the contents of /etc/locale.gen and /etc/environment before you corrected stuff manually (if you can still reproduce that)?

/etc/local.gen did not exist before we created it - now contains: en_US UTF-8 /etc/environment appears to have been created with the installation and contains:
LANG="en_US". None of the "LC_xxx" errors we saw indicated "en_US" as
a default.

Are there Debian analogs for Redhat's chkconfig, authconf and serviceconf? How do we allow logins from nis users? (ypbind has a
server but the users and paths are not recognized)

Sorry, these questions are off-topic for the debian-boot list. Please try debian-user instead. If needed, you may be able to get some IA64 specific help from the debian-ia64 mailing list.

Thanks for your report. Next time please consider sending a formal installation report [1].
Will do,
kindest regards,

[1] http://d-i.alioth.debian.org/manual/en.i386/ch05s03.html#submit-bug

Reply to: