[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: caveat: GNOME 2.6 severly broken on Debian/unstable?

>>>>> On Thu, 10 Jun 2004 15:36:39 +1000, Ian Wienand <ianw@gelato.unsw.edu.au> said:

  Ian> On Wed, Jun 09, 2004 at 11:13:16PM -0600, dann frazier wrote:

  >> I ran gdb on the two apps I've noticed exhibiting this problem -
  >> regchrome & gnome-session, both have the bundle loop issue
  >> described earlier in this thread, and both are in the same
  >> location in gnome_program_init(), which is part of libgnome.

  Ian> You can use the updated libgnome at 

  Ian> http://www.gelato.unsw.edu.au/~ianw/pango/

  Ian> until this is sorted out properly.

It looks like libgnomeprint may also be affected.  I (finally)
switched from lprng to CUPS today and as a result, gnumeric won't
start up.  It turns out that gnumeric gets stuck in a tight loop
inside libgnomeprint.  Looks like another one of those
relocations-got-dropped problems.

What's the status of getting these problems fixed properly?  It would
be good if we didn't have to find them one by one the hard way.

As a workaround, I dropped:

#LDFLAGS += -Wl,-z,defs

from libgnomeprint-2.6.2/debian/rules and rebuilt the package.  Now
gnumeric works fine again.


Reply to: