[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Building GLIBC

I'm having difficulty building glibc. First, it wouldn't find
linuxthreads even tho I specified --enable-add-ons
So I specified the linuxthreads directory but then it couldn't find
a header file in the linuxthreads directory. (After a rather long and
tortuous set of nested includes)
Finally, I moved the linuxthreads directory to be a subdirectory
of the head of the glibc tree. Now --enable-add-ons worked
without giving a directory but I got the message
TLS required I tried again adding --with-tls to the configure
options and now I get  (after make)
version GLIBC 2.3.3 not defined for libpthread
Since this is version 2.3.2 and is supposed to be the latest,
the error is a bit baffling.

The source is from a debian source package so I also
tried dpkg-deb -b glibc-2.3.2  First time it said no DEBIAN
sub-dir Well duh. It has a "debian" sub-dir Up cased debian
and tried again. This time says error at line 9
no package name, tho I didn't write it down.

So did I miss some essential step or is it supposed to
be this difficult?

Richard Harke

Reply to: