[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Installation on SGI Altix 350

Hello debian-ia64,

We are evaluating the SGI Altix platform, and got one with Red Hat

Now I tried to install Debian on it, but failed. I tried both beta-3
of the installer from 


as well as yesterday's daily build


with same results:

First I tried booting elilo from CD, with the kernel from CD and 
the initrd from CD (i.e. as it is probably intended by 
debian-installer). This resulted in the following:

  fs1:\> elilo -i initrd.gz linux ramdisk_size=24576 devfs=mount,dall root=/dev/ram0
  Uncompressing Linux... alloc.c(line 132):allocator:
  AllocatePages(2, 2, 1769, 0x4400000) failed (Not Found)

  gzip.c(line 436):gzip_ia64 : AllocatePages(1769, 0x4400000) for
  kernel failed

  gzip.c(line 439):relocation is disabled, cannot load kernel
  gzip.c(line 594):gzip_ia64 : invalid exec header
  Exit status code: Load Error

Then I tried booting the Red Hat kernel with the debian-installer
initrd, which result in much the same error, except that it tried
AllocatePages(3819, 0x4400000).

Then I tried to boot the debian kernel and initrd using the Red Hat
elilo. This first was more successful (managed to load the kernel),
but didn't really work as well:

  fs0:\efi\sgi> elilo -i atapi0:\initrd.gz atapi0:\linux ramdisk_size=24576 devfs=mount,dall root=/dev/ram0
  Uncompressing Linux... done
  Loading initrd atapi0:\initrd.gz...done
  POD entered via MCA, using Cac mode
  0 000: POD SysCt Cac>
Most success I had with Red Hat elilo, Red Hat kernel, and debian
initrd. With this combination I could enter debian-installer, do most of
the configuration (network, partitioning, etc.), but failed at the
installation of the base system. Debian-installer hinted me to check
/var/log/messages, which showed

dpkg: error processing /var/cache/apt/archives/libc6.1_2.3.2.ds1-11_ia64.deb (--unpack):
trying to overwrite `/etc/default/devpts', which is also in package initscripts
Errors were encountered while processing:

So, does anyone have any hints? First for the kernel; is it just the
case that the debian kernel won't work on the altix? Does it have a
different memory map than others, which generates the relocation problem?

And second for the "trying to overwrite": Is it possible to somewhere
put a "force-overwrite" in order to get the current sarge state
installed at all?

Thanks in advance!

Andreas Trottmann
Werft22 AG
Tel    +41 (0)56 210 91 37
Fax    +41 (0)56 210 91 34
Mobile +41 (0)79 229 88 55

Reply to: