[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: X11 and Elf_RelocateEntry()

On Monday 11 August 2003 11:36 am, David Mosberger wrote:
> >>>>> On Mon, 11 Aug 2003 12:48:17 +0200, Gregor Stößer
> >>>>> <stoesser@chemie.uka.de> said:
>   Gregor> I had the same problems, I tried XFree 4.1, 4.2 and 4.3, all
>   Gregor> withour success so I gave up using the NVidia driver. I know
>   Gregor> the 3D performance is twice as much as the one from XFree
>   Gregor> (at least on my x86 machines), but I don't think the time
>   Gregor> for getting the driver to work is it worth.  Sorry I have no
>   Gregor> better advice
> Debian/stable _should_ be fine.  In fact, my home machine is a zx2000
> with Debian/stable and I'm using the Nvidia driver (v4050).  It's
> working well.
> BTW: The zx2000 support web site has Nvidia driver v4431 available.  I
> haven't had a chance to try it out yet. It's available here (sorry for
> the long URL):
> http://h20004.www2.hp.com/soar_rnotes/bsdmatrix/matrix82074en_US.html#Drive
> 	--david
Based on the preceeding email, I decided to download XFree86
4.3.0 and go with that. Same problem. Then after considerable
thinking I decided to try compiling it with gcc-2.96 (Debian set the
default compiler on my system to gcc-3.3) This made a large
difference but whether for the better is open to question. The first
time I tried startx, it said no screen this is with the XF86Config-4
installed by Nvidia. So I changed to the config file from my other
machine, also nvidia ( and is sharing the monitor via KVM switch)
second try, it came up, but with the twm window manager. Wanting
KDE, I did ctrl-alt-backspace to shutdown X The machine hung.
Finally had to power down. On re-power, it complained
about the disk and prompted to have fsck run manually. But
it wasn't listening to the keyboard -- dead in the water
Finally used recovery shell to fsck and then was able to boot
before trying again, I did a telnet to the machine first in hopes
I could regain control if things went bad. No such luck.
I did startx kde3 but intead of starting KDE, it passed kde to
xterm as a param and it died during start up. The telnet session
didn't help as it went dead with the rest. I guess the kernel
is crashed so bad it can't even say "PANIC" Had to use
recovery shell again.

I'm open to suggestions.


Reply to: