[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Fwd: Fwd: Does not work enteri­ng Ru­ssian characters


I do not know where to write.

I sent a bug report, but did not receive any notifications, bug among registered can not see.

I wrote to your robot on submit@bugs.debian.org and to owner@bugs.debian.org.

----- Пересылаемое письмо -----
Дата: Птн 15 Май 2015 14:50:35 +0300
От: Constantine <aureliano@pochtamt.ru>
Тема: Fwd: Does not work enteri­ng Ru­ssian characters
Кому: owner@bugs.debian.org


Yesterday sended bug-report, but not received reply.

----- Forwarded message -----
Date: Thursday 14 May 2015 22:29:26 +0300
From: Constantine <aureliano@pochtamt.ru>
Subject: Does not work entering Ru­ssian characters
To: submit@bugs.debian.org

Package: debian-i18n
Version: 8.0
Severity: important

In a number of programs in Debian 8 input does not work for Cyrillic characters (for example, in Iceweasel, Chromium, pluma, GIMP, LibreOffice Writer, mate-terminal, the program of unlock off session Mate (password) - this is what I have tried. I think, with the majority other programs the same story). At the same time Russian characters are inserted from the clipboard, and their possible enter on a screen virtual-keyboard, if any present in a program (for example, screen virtual-keyboard in the search box of google and yandex in web browsers). Unable to enter Russian characters with physical keyboard.

Especially unclear behaves Google Chromium browser: when you run it allows you to enter the Cyrillic symbols in the address bar, but only 1 time. After pressing Enter to re-introduce the Cyrillic symbols is not possible. If you try to enter the Cyrillic symbols is not in the address, but in the search box, it is not entered. And after such attempts have not introduced the Cyrillic symbols in the address bar.

The rest of the listed programs, including Iceweasel, behave more simply: they simply do not allow you to enter the Cyrillic alphabet with the hardware keyboard ever.

This problem is not observed in Konqueror, KWrite, Kate, KMail, Konsole, as well as in xterm, uxterm and in text console without X11, as well as in window of unlock of session KDE (password) and in window of input login (login / password) .

It seems that the problem does not apply to text mode and to KDE. In programs under Mate problem presents. In other X-programs - sometimes - yes (in Iceweasel) and sometimes - no (as in xterm), probably depending on used libraries.

OS Debian Linux 8.0 amd64, the kernel 3.16.7, graphics subsystems Mate and KDE (tried both), a computer - the most common is not very new office desktop with 2 cores and 1 GB. memory, and the most common standard ps/2 keyboard Deluxe. In other OS all right.

Tried in the file /etc/init.d/kbd replace the 93rd row

mode = "` (LC_ALL = C; export LC_ALL; kbd_mode) 2> & 1` "


mode = "` (LC_ALL =; export LC_ALL; kbd_mode) 2> & 1` "

- does not help.

Output "uname -a":

Linux makondo 3.16.0-4-amd64 # 1 SMP Debian 3.16.7-ckt9-3 ~ deb8u1 (2015-04-24) x86_64 GNU / Linux

Output "lsb_release -a":

No LSB modules are available.
Distributor ID: Debian
Description: Debian GNU / Linux 8.0 (jessie)
Release: 8.0
Codename: jessie

Output "locale":

LANG = ru_RU.UTF-8
LC_CTYPE = "ru_RU.UTF-8"
LC_TIME = "ru_RU.UTF-8"
LC_PAPER = "ru_RU.UTF-8"
LC_NAME = "ru_RU.UTF-8"

Output "dpkg -s libc6 | grep ^Version":

Version: 2.19-18

Output "reportbug -q --template -T none -s none -S normal -b --list-cc none -q debian-i18n":

Detected character set: UTF-8
Please change your locale if this is incorrect.

Using '"Constantine S. Ljapin" <aureliano@pochtamt.ru>' as your from address.
Will send report to Debian (per lsb_release).

Rewriting subject to 'debian-i18n: none'
Content-Type: text/plain; charset="us-ascii"
MIME-Version: 1.0
Content-Transfer-Encoding: 7bit
From: "Constantine S. Ljapin" <aureliano@pochtamt.ru>
To: Debian Bug Tracking System <submit@bugs.debian.org>
Subject: debian-i18n: none
X-Debbugs-Cc: aureliano@pochtamt.ru, none

Package: debian-i18n
Severity: normal

Dear Maintainer,

*** Reporter, please consider answering these questions, where appropriate ***

   * What led up to the situation?
   * What exactly did you do (or not do) that was effective (or
   * What was the outcome of this action?
   * What outcome did you expect instead?

*** End of the template - remove these template lines ***

-- System Information:
Debian Release: 8.0
  APT prefers stable-updates
  APT policy: (500, 'stable-updates'), (500, 'stable')
Architecture: amd64 (x86_64)

Kernel: Linux 3.16.0-4-amd64 (SMP w/2 CPU cores)
Locale: LANG=ru_RU.UTF-8, LC_CTYPE=ru_RU.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)
----- End of forwarded message -----
----- Конец пересылаемого письма -----

Best regards. Constantine.

Reply to: