[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Greek accents in KDE




On 11/07/2005, at 5:19 AM, Simos Hadjiyiannis wrote:

I am running Debian 3.1 and I am trying to get Greek accents
to work in KDE. I have configured languages, keyboard layouts,
etc. and I can type Greek characters without any problems.

However, when I try to type in a character with an accent (e.g.
epsilon with ') in a KDE editor (e.g. KWord) it does not work:
I type ; on my keyboard (which is a deadkey in the Greek layout
for the acute accent), nothing appears on the screen (which is
expected), then I type in the epsilon, but nothing happens.
If I type ; twice, I get the accent by itself. If I type
epsilon twice, I get the epsilon character without any accent.

The strange thing is, this works fine on all Gnome apps (e.g
Abiword, Firefox, etc.) even when I'm running them in KDE.

I would appreciate any help or hints. It's been driving me
batty the last few hours.

Simos, you interest me very much with this! I am having similar problems with KDE in X11 on Mac OSX. When I use a dead key on my Unicode Vietnamese keyboard (which should do nothing until I type the vowel afterwards, then it adds that accent to the vowel typed), I get a space instead, and no accent on the following vowel! I can't type added accents at all!

For example, instead of three e graves in a row, I'll get:

 e e e

I haven't got many programs running under X11, so I can't compare the input in any detail. Vietnamese input and display is correct under the Mac OSX GUI (10.4.1), and I have my prefs set correctly in X11, but I can't input added accents at all. I can't do it in xterm either, but I don't know what that means. :(

I hope this is of some help to you. I've posted about it on the Mac OSX HInts forums, and the Xfree86 maiing list, and only received a deafening silence in return. :(

The Kbabel developer is very interested, but I can't really give him the information he needs, since I know so little about KDE. What happens when you try to input added accents in Kbabel? Does accented text in a loaded text file display correctly?

Is there anyone here who is inputting added accents in KDE on either of our operating systems? I think we'd both appreciate any help we can get. I've got rather beyond batty by now. :(

from Clytie (vi-VN, Vietnamese free-software translation team / nhóm Việt hóa phần mềm tự do)
http://groups-beta.google.com/group/vi-VN




Reply to: