[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Installation report of the July 1st version of the debian installer image

> Hey everyone :)
> the filesystem of my hurd box died some time ago, only the root
> filesystem, probably because of the sync problems on shutdown. The box
> is an athlon 1.5Ghzish, 512MByte of ram, 40 gig hard drive, two nics,
> one rtl8139c that works fine with gnumach, one sis900 that works both
> with gnumach (well I think it does, not sure thoug) and a dde userspace
> driver (that was a nice experience, unfortunately the server died every
> now and then). So I downloaded the current (2011-07-01) version of
> Samuels images and bootet the system.

Hi, I just downloaded the current (2011-07-21) version of Samuel's
cd-1.iso install CD and got to similar trouble as you described.

> Impressions:
> * Xorg failed to use the correct resolution / refresh rates, monitor
> driven out of spec (19" flat screen). I never tried Xorg on that box
> before, so I can't say whether this is specific to the installer or
> not.

For me, Xorg goes fine, but the hurd console (pseudo-graphical
installer) run some of my montors out of spec.

> * Locating the cdrom drive takes a long time, some error messages are
> printed to stderr ('end_request: I/O error, dev 02:00, sector 0',
> once more for 02:01)

Same here (but not so long delay, only about 30 secs). But I have two cd
(dvd) drives and I suppose that these "errors" come from the second
drive attempting to access a CD while the drive is empty. May be it
would be possible to check whether there is a CD in the drive in order
to shorten this delay, but this is probably a minor issue. Inserting
some CD in the second drive got rid of that I/O errors.

> * I tried normal installation about five times, without restarting the
> installer, just running the partitioner and base install over and
> over again.
> * It failed at various points within the debootstrap process

Same here. And as you pointed out, the faults were also here caused by
garbage in the beginning of some file (the affected files were different
in each run of the installer).

> for example 'Warning: Failure trying to run:
> chroot /target /usr/lib/hurd/setup-translators -k'. The beginning of
> that file contained a small number of garbage bytes, the rest of the
> file looked fine. /var/log/messages contained
> 'debootstrap: /usr/lib/hurd/setup-translators /usr/lib/hurd/setup-translators:
> cannot execute binary file'.

> * the filesystem is not umounted if the installation failed, not sure

Same here, while trying to format a partition, it says something like
"Could not check whether /target is mounted, because the file /etc/mtab
does not exist." on VT4.

> what the consequence was, maybe the partitioner was failing or it
> wasn't possible to format the partition and keeping the files was
> not my intention...
> Let me say that despite the fact that the installation failed I am very
> impressed and it has been a nice adventure to explore the state of the
> debian installer on the Hurd :)

Same here :)

> Any thoughts?
> Justus

Best regards,
Tomas "trosos" Tintera

Reply to: