[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Build of emacs_23.2+1-7

On Thu, 2011-03-17 at 18:41 +0100, Arne Babenhauserheide wrote:
> On Wednesday 16 March 2011 16:30:40 Svante Signell wrote:
> > Attached! Please let me know if you need any of the built .debs or
> > the .orig.tar.gz file
> I need to know how to install it :) 
> (My Hurd is running nicely again, now, and I have my tools ready for 
> installing)
> I normally use Gentoo, so I’m not familiar with the way to install using your 
> tarball.

Did you install Debian GNU/Hurd using the Debian installer in mini.iso
under Gentoo GNU/Linux? Or are you running some other version of GNU/Hurd?

In case you installed Debian GNU/Hurd then you need to do the following
to build from source:
apt-get source emacs23
apt-get build-dep emacs23 (as root)
Replace the downloaded emacs23_23.2+1-7.debian.tar.gz with the one I
sent you. Unpack again overwriting parts of the old emacs23.2+1-7/
cd emacs23.2+1-7
dpkg-buildpackage -b

(wait for a rather long time)

The built packages are built and stored in ../
cd ..
dpkg -i emacs23-bin-common_23.2+1-7_hurd-i386.deb emacs23-common_23.2\
+1-7_all.deb emacs23-nox_23.2+1-7_hurd-i386.deb

(unfortunately emacs does not work under X-windows yet)

In case you need the *.el-files
dpkg -i emacs23-el_23.2+1-7_all.deb

If you need my (non-signed) built packages I can send them privately.

Reply to: