[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Error when running native-install

On Fri, 2010-04-09 at 17:15 +0200, Samuel Thibault wrote:
> Patrik Olsson, le Fri 09 Apr 2010 16:56:50 +0200, a écrit :
> > On Fri, 2010-04-09 at 15:35 +0200, Samuel Thibault wrote:
> > > Patrik Olsson, le Fri 09 Apr 2010 15:13:17 +0200, a écrit :
> > > > What am I doing wrong?
> > > 
> > > We can't say if you do not tell us what you do before ./native-install,
> > > i.e. the grub configuration etc.
> > > 
> > 
> > I followed this guide from point 5 (using grub1):
> > http://www.debian.org/ports/hurd/hurd-install
> Well, ok, but I had checked that the steps described in that guide do
> work, so there is a problem of interpretation, we need to you explain
> with your own words which precise commands you run. Simple things like
> an extra --readonly or -s is already too much for native-install to
> work.

Well, the guide says to include -s on kernel line... (in any case, I
tested without it and the native-install script still fails)

I don't remember exactly what I executed before/while installing the
system. Basically I got the partition up using a Debian GNU/Linux
installation disc and then from the Debian GNU/Hurd L1 installation
mini-iso I mounted the partition and did the base installation
(extracting baseGNU.tgz is what I read it did).

This is exactly what I wrote on the grub prompt (and which is now
executed automatically):

root (hd0,0)
kernel /boot/gnumach.gz root=device:hd0s1 -s
module /hurd/ext2fs.static --multiboot-command-line=${kernel-command-line} --host-priv-port=${host-port} --device-master-port=${device-port} --exec-server-task=${exec-task} -T typed ${root} $(task-create) $(task-resume)
module /lib/ld.so.1 /hurd/exec $(exec-task=task-create)

Then in the shell I write:

export TERM=mach

> > As I understand it, the installation simply extracts a file called
> > baseGNU.tgz (at least that's the only thing I noticed it did). So
> > shouldn't it be possible to include grub configuration in it
> > (/boot/grub/?)
> Probably. Contact the author.

Who is the author? It's about the Debian GNU/Hurd installation CD so
wouldn't this mailing list be the best place to bring it up? (I mean,
isn't the author here?)

> > > > It takes like 5 minutes to write in all that magic to get GRUB
> > > > starting the Hurd, and it is so error-prone.
> > > 
> > > You can throw them in a config file and load it from the grub prompt
> > > thanks to the configfile command...
> > 
> > I tried that, but it didn't work (I probably messed up, I had to write
> > the file using cat).
> Without describing the precise steps you followed, there is no way to
> find out whether there is a bug that deserves fixing, or whether you
> actually just messed up (but then the installation instruction probably
> need fixing !!)

The GRUB commands I wrote above is exactly what I wrote
into /boot/grub/menu.lst. When GRUB starts I did:

root (hd0,0)
configfile /boot/grub/menu.lst

But that just resets to the empty GRUB prompt. But nevermind, I have
worked around it by using another preconfigured GRUB image.

I noticed another warning message on boot about device:hd0s1 being
mounted read-only, and that I must use "fsysopts --writable". I tried
that (actually I had to do "fsysopts / --writable" for the command to
succeed), but native-install would still fail in the same way as

I guess it has something to do with the system being mounted read-only.
I also tried "fsysopts hd0s1 --writable" and "fsysopts device:hd0s1
--writable", but none of them worked (the commands didn't succeed).


Attachment: signature.asc
Description: This is a digitally signed message part

Reply to: