[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Non root sudo + aptitude


It seems that aptitude works under root, meaning one can install
packages and upgrade them under root.  However under a non root user,
with sudo set so that aptitude can be run, then everything works,
except for the fact that after downloading the packages, if the
packages were requested through command line, the next error shows up:

Preconfiguring packages ...
E:  Sub-process /usr/sbin/dpkg exited unexpectedly
A package failed to install.  Trying to recover:

And the machine hangs.  If the packages were issued through the
ncurses interface, then the error doesn't show up, but the machine
hangs as well...

I prefer to use aptitude through sudo as a non root user, but the work
around is to use it under root for now, or to use "apt-get install"
for the packages aptitude tried to install, since as they were tried
by aptitude, they will be understood by it...  Hopefully some one will
find the issue, :).



Reply to: