[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: cross-debootstraped rootfs is failing to boot


On Sun, Sep 30, 2007 at 11:34:03PM +0530, Praveen A wrote:
> 2007/9/30, Thomas Schwinge <tschwinge@gnu.org>:
> > What happens if you run a ``touch [...]/servers/exec'' to create an empty
> > node with the expected name?
> >
> I tried it on a real machine with a partition created with -o hurd
> option for debootstrap target (as suggested by Michael Bank on IRC),
> but failed to boot with the same error.

The file system you are booting from indeed has to be a ``Hurd'' one, but
the one you run `debootstrap' one needn't, as no passive translators are
being set-up during that process.

> Now as per your suggestion I copied /servers/exec from another
> installation (K14) and it proceeded

`touch'ing it would have been enough.

> failed saying /dev/console not found.
> I copied /dev/console also from my other installation it failed with
> error Read only filesystem.

Copying won't work as it's a passive translator setting (which is
currently not accessible from Linux-based systems).  Does your Hurd file
system have an (empty) `/tmp' directory?  A fallback console should
automatically be created in there during the boot process, as long as the
passive translators inside `/dev/' haven't been set-up.  Please try this:

$ cd [...]
$ rm dev/console
$ mkdir tmp
$ chmod 01777 tmp

If a `/tmp' directory already did exist, then please show the complete

> /hurd/ext2fs.static has a --readonly option, did that cause this problem?

No.  Hurd systems are usually booted this way.


Attachment: signature.asc
Description: Digital signature

Reply to: