[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

crosshurd problem

Hi !

I tried installing debian/hurd through crosshurd on debian/linux
unstable.  I got the problem indicating:

util-linux:  Predepends:  slang1a-utf8 (>1.4.4-7.1)

I searched for the repositories and that package wasn't there.
Instead there was lislang2 with higher version.

The complaining util-linux package comes from version 2.12-3 under
unstable, while under unreleased the version is 2.12-3+hurd2, and the
unreleased version doesn't depend upon this slang1a package but
instead upon slang2 one:

libslang2 (>=2.0.1-1)

The version available under unstable is even higher, so I guess the
unreleased version of util-linux is correct while the unstable isn't.

I tried fixing the preferences of crosshurd reducing the unstable
Pin-Priority from 990 to 980 and then 970 without success.  Notice the
unreleased Pin-Priority is 995.  So I didn't know how to make
crosshurd use the unreleased version instead of the unstable one.

I also tried not using the unstable repositories, but that's useless,
since there are several required packages only there.

I tried modifying the Packages list so that I could remove from
unstable the listed util-linx package, but I got MD5SUM mismatches,
and then I tried just changing the dependency from what it originally
included to what the unreleased Packages list included for it, and
again I got MD5SUM mismatches.

One thing I need to mention is that I have the repositories mirrorred
locally in my disk since I don't have internet connection at home.
I'm right now upgrading the mirror (apt-mirror is a pretty nice tool)
from the office, but I don't know if that's enough to fix the problem.
Initially it sounds more like a crosshurd problem to me since it's
not able to pick the unreleased version over the unstable...

Is there a way to overcome this?

Thanks a lot,


Reply to: