[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Emacs24.4.1 followup

On Mon, Apr 18, 2005 at 11:23:20PM +0200, Thomas Schwinge wrote:
> On Sat, Apr 16, 2005 at 05:44:41PM -0400, Barry deFreese wrote:
> > Well I moved the debs I built on clubber to flubber and now I get the 
> > segfault on installing emacs..
> I built (better: tried to build) emacs-21.3 on an up-to-date Debian
> GNU/Hurd system using only Debian's hurd-libio-glibc.dpatch and
> CFLAGS='-O0 -g -pipe'.
> For those who have not yet seen it for theirselves:
> #v+
> [...]
> ../src/bootstrap-emacs -batch --no-site-file --multibyte -l autoload --eval '(setq generated-autoload-file "/var/tmp/build/emacs/emacs-21.3/lisp/loaddefs.el
> ")' -f batch-update-autoloads $wins
> Directories: /var/tmp/build/emacs/emacs-21.3/lisp /var/tmp/build/emacs/emacs-21.3/lisp/calendar /var/tmp/build/emacs/emacs-21.3/lisp/emacs-lisp /var/tmp/bui
> ld/emacs/emacs-21.3/lisp/emulation /var/tmp/build/emacs/emacs-21.3/lisp/eshell /var/tmp/build/emacs/emacs-21.3/lisp/gnus /var/tmp/build/emacs/emacs-21.3/lis
> p/international /var/tmp/build/emacs/emacs-21.3/lisp/language /var/tmp/build/emacs/emacs-21.3/lisp/mail /var/tmp/build/emacs/emacs-21.3/lisp/net /var/tmp/bu
> ild/emacs/emacs-21.3/lisp/obsolete /var/tmp/build/emacs/emacs-21.3/lisp/play /var/tmp/build/emacs/emacs-21.3/lisp/progmodes /var/tmp/build/emacs/emacs-21.3/
> lisp/term /var/tmp/build/emacs/emacs-21.3/lisp/textmodes /var/tmp/build/emacs/emacs-21.3/lisp/toolbar
> Fatal error (11)./bin/sh: line 1: 24027 Segmentation fault      ../src/bootstrap-emacs -batch --no-site-file --multibyte -l autoload --eval '(setq generated
> -autoload-file "/var/tmp/build/emacs/emacs-21.3/lisp/loaddefs.el")' -f batch-update-autoloads $wins
> make[2]: *** [autoloads] Error 139

For some added bogosity, I managed to build emacs21, with a quite
similar setup as Thomas described above.  However, it only works fine
(and really fine, as in no problems so far) if I run it from inside the
chroot I built it in.  As soon I run it from my main root (either the
binary in the chroot or the one installed in the main root), I either
immediately or eventually (trying to find ~/.bash<tab> seems reliable
here) get a segfault (with a similar stack trace as Thomas).  As this
also happens when doing byte compiling, the package does not install
properly (as stuff gets byte compiled in the postinst).



Michael Banck
Debian Developer

Reply to: