[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Still want to believe.

On Thu, 20 Nov 2003, Steve King wrote:

> Sorry in advance for the troll,
> I am trying to get to grips with the hurd. It seems to me like it
> has gone backwards since I last dipped my toe in a couple of years
> ago. Have I just got the wrong set up?
> I installed using crosshurd, so it should be up-to-date, but
> it seems highly broken.
> vi dumps a core

Try nano. Works great.

> telnet dumps a core

Not tried it recently. Try slogin.

> I can't get the nfs translator to work

Not tried it recently either, so I can't say about this.

> there is no ftp client

Try installing inetutils-ftp.

> sshd dumps a core

Not for me. I got segfaults from dpkg trying to upgrade it from a
previous version. I wrote a dummy start-stop-daemon which did
nothing, like this: "#!/bin/sh", put it in /local/bin, and managed to
upgrade it. After this it has always worked flawlessly.

> inetd dumps a core
> I get a linking error trying to build gnu mach
> strpcpy.
> It took me a day of instant reboots to realise that
> it didn't like the fact that I had too much memory (I went from
> 1GBbyte to 512Mbytes)

I also had this problem, and fixed it by adding this:

uppermem        786432

to GRUB's menu.lst.

> I would really love to do some work on the hurd, but the only
> way I can copy files is by booting into sid. And that is
> just not realistic. Life is too short.
> So please, should I use an older version? How can I believe
> that the hurd is a good thing if it is impossible to use?

Try using the old tarball from Marcus, which is still available here:


My system, which does not crash so often, is based on this tarball
(plus "apt-get upgrade" to current packages).

The main difference, perhaps, is that I'm still using the monolithic
inetutils which contained everything (because apt-get upgrade does not
upgrade to the current inetutils-* packages). I don't think this is
the reason for your core dumps, but who knows?

Reply to: